summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
commite230b6f78546827521107be23797048482c8b193 (patch)
tree948c1e77382c484819ea399bba4edcdc19cc6bf0 /plugins/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parent49120f48474fc8fdc2448c75d961bc238213cfac (diff)
Update upstream source from tag 'upstream/0.28.2'
Update to upstream version '0.28.2' with Debian dir 811236a8e9a1308bf427065dcb6270419ff4f965
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 0000000..66096c7
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,24 @@
+# Plugin helper library
+
+sw_plugin_common = library('shotwell-plugin-common',
+ ['common/RESTSupport.vala',
+ 'common/Resources.vala',
+ 'common/WebAuthenticationPane.vala',
+ 'common/BuilderPane.vala',
+ 'common/OAuth1Support.vala'],
+ version: meson.project_version(),
+ dependencies : [gtk, gee, webkit, soup, xml, sw_plugin],
+ vala_header : 'shotwell-plugin-common.h',
+ vala_vapi : 'shotwell-plugin-common.vapi',
+ include_directories : config_incdir,
+ install : true)
+
+sw_plugin_common_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : sw_plugin_common)
+
+subdir('authenticator')
+subdir('shotwell-publishing')
+if get_option('enable-extra-plugins')
+ subdir('shotwell-publishing-extras')
+endif
+subdir('shotwell-transitions')