summaryrefslogtreecommitdiff
path: root/plugins/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
commit2b3f22361da0c1d8e6ce70d71352821758186db7 (patch)
tree5d10633b47369b3aa52a05bf889ede0dbe5ee108 /plugins/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parentdc6c76eb04dfe3d4262a1806808f0bc0bf523238 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'plugins/meson.build')
-rw-r--r--plugins/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/plugins/meson.build b/plugins/meson.build
new file mode 100644
index 0000000..66096c7
--- /dev/null
+++ b/plugins/meson.build
@@ -0,0 +1,24 @@
+# Plugin helper library
+
+sw_plugin_common = library('shotwell-plugin-common',
+ ['common/RESTSupport.vala',
+ 'common/Resources.vala',
+ 'common/WebAuthenticationPane.vala',
+ 'common/BuilderPane.vala',
+ 'common/OAuth1Support.vala'],
+ version: meson.project_version(),
+ dependencies : [gtk, gee, webkit, soup, xml, sw_plugin],
+ vala_header : 'shotwell-plugin-common.h',
+ vala_vapi : 'shotwell-plugin-common.vapi',
+ include_directories : config_incdir,
+ install : true)
+
+sw_plugin_common_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : sw_plugin_common)
+
+subdir('authenticator')
+subdir('shotwell-publishing')
+if get_option('enable-extra-plugins')
+ subdir('shotwell-publishing-extras')
+endif
+subdir('shotwell-transitions')