summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:43:08 +0200
commit2b3f22361da0c1d8e6ce70d71352821758186db7 (patch)
tree5d10633b47369b3aa52a05bf889ede0dbe5ee108 /plugins/shotwell-publishing/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parentdc6c76eb04dfe3d4262a1806808f0bc0bf523238 (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'plugins/shotwell-publishing/meson.build')
-rw-r--r--plugins/shotwell-publishing/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/plugins/shotwell-publishing/meson.build b/plugins/shotwell-publishing/meson.build
new file mode 100644
index 0000000..45058b8
--- /dev/null
+++ b/plugins/shotwell-publishing/meson.build
@@ -0,0 +1,25 @@
+shotwell_publishing_sources = [
+ 'shotwell-publishing.vala',
+ 'FacebookPublishing.vala',
+ 'PicasaPublishing.vala',
+ 'FlickrPublishing.vala',
+ 'TumblrPublishing.vala',
+ 'YouTubePublishing.vala',
+ 'PiwigoPublishing.vala']
+
+shotwell_publishing_resources = gnome.compile_resources('publishing-resource',
+ 'org.gnome.Shotwell.Publishing.gresource.xml',
+ source_dir : meson.source_root())
+
+shared_module('shotwell-publishing',
+ shotwell_publishing_sources + shotwell_publishing_resources,
+ dependencies : [gtk, soup, gexiv2, gee, sw_plugin, json_glib,
+ webkit, sw_plugin_common_dep, xml, gdata, gcr,
+ gcr_ui, authenticator_dep],
+ vala_args : [
+ '--gresources', 'org.gnome.Shotwell.Publishing.gresource.xml'
+ ],
+ c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing"',
+ '-DGCR_API_SUBJECT_TO_CHANGE'],
+ install: true,
+ install_dir : shotwell_plugin_dir)