summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
commite230b6f78546827521107be23797048482c8b193 (patch)
tree948c1e77382c484819ea399bba4edcdc19cc6bf0 /plugins/shotwell-publishing/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parent49120f48474fc8fdc2448c75d961bc238213cfac (diff)
Update upstream source from tag 'upstream/0.28.2'
Update to upstream version '0.28.2' with Debian dir 811236a8e9a1308bf427065dcb6270419ff4f965
Diffstat (limited to 'plugins/shotwell-publishing/meson.build')
-rw-r--r--plugins/shotwell-publishing/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/plugins/shotwell-publishing/meson.build b/plugins/shotwell-publishing/meson.build
new file mode 100644
index 0000000..45058b8
--- /dev/null
+++ b/plugins/shotwell-publishing/meson.build
@@ -0,0 +1,25 @@
+shotwell_publishing_sources = [
+ 'shotwell-publishing.vala',
+ 'FacebookPublishing.vala',
+ 'PicasaPublishing.vala',
+ 'FlickrPublishing.vala',
+ 'TumblrPublishing.vala',
+ 'YouTubePublishing.vala',
+ 'PiwigoPublishing.vala']
+
+shotwell_publishing_resources = gnome.compile_resources('publishing-resource',
+ 'org.gnome.Shotwell.Publishing.gresource.xml',
+ source_dir : meson.source_root())
+
+shared_module('shotwell-publishing',
+ shotwell_publishing_sources + shotwell_publishing_resources,
+ dependencies : [gtk, soup, gexiv2, gee, sw_plugin, json_glib,
+ webkit, sw_plugin_common_dep, xml, gdata, gcr,
+ gcr_ui, authenticator_dep],
+ vala_args : [
+ '--gresources', 'org.gnome.Shotwell.Publishing.gresource.xml'
+ ],
+ c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing"',
+ '-DGCR_API_SUBJECT_TO_CHANGE'],
+ install: true,
+ install_dir : shotwell_plugin_dir)