summaryrefslogtreecommitdiff
path: root/plugins/shotwell-transitions/meson.build
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-05-01 14:35:32 +0200
commite230b6f78546827521107be23797048482c8b193 (patch)
tree948c1e77382c484819ea399bba4edcdc19cc6bf0 /plugins/shotwell-transitions/meson.build
parent211da5fc3048ca2b6ccee2166b0aaaade55cb84f (diff)
parent49120f48474fc8fdc2448c75d961bc238213cfac (diff)
Update upstream source from tag 'upstream/0.28.2'
Update to upstream version '0.28.2' with Debian dir 811236a8e9a1308bf427065dcb6270419ff4f965
Diffstat (limited to 'plugins/shotwell-transitions/meson.build')
-rw-r--r--plugins/shotwell-transitions/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/shotwell-transitions/meson.build b/plugins/shotwell-transitions/meson.build
new file mode 100644
index 0000000..8134292
--- /dev/null
+++ b/plugins/shotwell-transitions/meson.build
@@ -0,0 +1,29 @@
+shotwell_transitions_sources = [
+ 'BlindsEffect.vala',
+ 'ChessEffect.vala',
+ 'CircleEffect.vala',
+ 'CirclesEffect.vala',
+ 'ClockEffect.vala',
+ 'CrumbleEffect.vala',
+ 'FadeEffect.vala',
+ 'shotwell-transitions.vala',
+ 'SlideEffect.vala',
+ 'SquaresEffect.vala',
+ 'StripesEffect.vala']
+
+shotwell_transitions_resources = gnome.compile_resources('transitions-resource',
+ 'org.gnome.Shotwell.Transitions.gresource.xml')
+
+cc = meson.get_compiler('c')
+libm = cc.find_library('m', required : false)
+
+shared_module('shotwell-transitions',
+ shotwell_transitions_sources + shotwell_transitions_resources,
+ dependencies : [gio, gdk_pixbuf, cairo, gtk, gdk, xml, sw_plugin,
+ sw_plugin_common_dep, gee, soup, webkit, libm],
+ vala_args : [
+ '--gresources', 'org.gnome.Shotwell.Transitions.gresource.xml',
+ ],
+ c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Transitions"'],
+ install: true,
+ install_dir : shotwell_plugin_dir)