summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules7
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cacfc36..67639da 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ shotwell (0.30.14-2) UNRELEASED; urgency=medium
* Enable untiy support (Closes: #1000528)
- debian/control: Add Build-Depends libunity-dev.
- debian/rules: Add override_dh_auto_configure.
+ * debian/rules:
+ - enable the apport option on Ubuntu (Closes: #1000529).
-- Jörg Frings-Fürst <debian@jff.email> Sat, 27 Nov 2021 09:39:19 +0100
diff --git a/debian/rules b/debian/rules
index acbfebd..a772218 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,13 +4,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
%:
dh $@ --buildsystem=meson --with gnome
override_dh_auto_configure:
dh_auto_configure -- \
--libexec=/usr/libexec \
- -Dunity-support=true
+ -Dunity-support=true $(APPORT)
override_dh_gnome_clean:
dh_gnome_clean --no-control