summaryrefslogtreecommitdiff
path: root/debian/patches/0001-buildflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-buildflags.patch')
-rw-r--r--debian/patches/0001-buildflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/0001-buildflags.patch b/debian/patches/0001-buildflags.patch
new file mode 100644
index 0000000..91ca3a0
--- /dev/null
+++ b/debian/patches/0001-buildflags.patch
@@ -0,0 +1,20 @@
+Description: Poke requested Debian buildflags for hardening into Makefile
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 2015-01-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/Makefile
+===================================================================
+--- trunk.orig/Makefile
++++ trunk/Makefile
+@@ -385,8 +385,8 @@ PLUGIN_CFLAGS = -O2 -g -pipe
+ endif
+ endif
+
+-CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS)
+-PLUGIN_CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS)
++CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS) -fstack-protector-strong
++PLUGIN_CFLAGS += $(PROFILE_FLAGS) $(REQUIRED_CFLAGS) -fPIC -fno-stack-protector
+
+ # Required for gudev-1.0
+ CFLAGS += -DG_UDEV_API_IS_SUBJECT_TO_CHANGE