summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/hardening.patch38
-rw-r--r--debian/patches/libexec.patch16
-rw-r--r--debian/patches/series2
3 files changed, 56 insertions, 0 deletions
diff --git a/debian/patches/hardening.patch b/debian/patches/hardening.patch
new file mode 100644
index 0000000..33d92a6
--- /dev/null
+++ b/debian/patches/hardening.patch
@@ -0,0 +1,38 @@
+Description: pass compiler flags set in debian/rules to compiler
+Author: Devid Antonio Filoni <d.filoni@ubuntu.com>
+
+Index: trunk/Makefile
+===================================================================
+--- trunk.orig/Makefile 2014-10-09 12:18:23.260829459 +0200
++++ trunk/Makefile 2014-10-09 12:18:23.252829340 +0200
+@@ -35,7 +35,7 @@
+ LOCAL_LANG_DIR=locale-langpack
+ SYSTEM_LANG_DIR := $(DESTDIR)$(PREFIX)/share/locale
+
+-VALAFLAGS := -g --enable-checking --target-glib=2.32 --thread --fatal-warnings --enable-experimental --enable-deprecated $(USER_VALAFLAGS)
++VALAFLAGS := $(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w)) --enable-checking --target-glib=2.32 --thread --enable-experimental --enable-deprecated $(USER_VALAFLAGS)
+ ifdef UNITY_SUPPORT
+ VALAFLAGS := $(VALAFLAGS) --define UNITY_SUPPORT
+ endif
+@@ -671,7 +671,7 @@
+ @
+
+ $(EXPANDED_OBJ_FILES): %.o: %.c $(CONFIG_IN) Makefile
+- $(CC) -c $(VALA_CFLAGS) $(CFLAGS) -o $@ $<
++ $(CC) -c $(VALA_CFLAGS) $(CPPFLAGS) $(CFLAGS) -o $@ $<
+
+ $(PROGRAM): $(EXPANDED_OBJ_FILES) $(RESOURCES) $(LANG_STAMP) $(THUMBNAILER_BIN) misc/gschemas.compiled $(DOC_LANG_STAMP)
+ $(CC) $(EXPANDED_OBJ_FILES) $(CFLAGS) $(LDFLAGS) $(RESOURCES) $(VALA_LDFLAGS) $(EXPORT_FLAGS) -o $@
+Index: trunk/plugins/Makefile.plugin.mk
+===================================================================
+--- trunk.orig/plugins/Makefile.plugin.mk 2014-10-09 12:18:23.260829459 +0200
++++ trunk/plugins/Makefile.plugin.mk 2014-10-09 12:19:22.945701585 +0200
+@@ -41,7 +41,7 @@
+ all: $(PLUGIN).so
+
+ .stamp: $(SRC_FILES) $(MAKE_FILES) $(HEADER_FILES)
+- $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --fatal-warnings --save-temps --compile --enable-deprecated \
++ $(VALAC) --target-glib=$(MIN_GLIB_VERSION) -g --enable-checking --save-temps --compile --enable-deprecated \
+ --vapidir=../ $(foreach pkg,$(PKGS),--pkg=$(pkg)) $(foreach pkg,$(CUSTOM_VAPI_PKGS),--pkg=$(pkg)) \
+ -X -I../.. -X -fPIC \
+ $(foreach dfn,$(DEFINES),-X $(dfn)) \
diff --git a/debian/patches/libexec.patch b/debian/patches/libexec.patch
new file mode 100644
index 0000000..0e06218
--- /dev/null
+++ b/debian/patches/libexec.patch
@@ -0,0 +1,16 @@
+Description: do not install files in libexec directory
+Author: Luca Falavigna <dktrkranz@debian.org>
+
+Index: shotwell-0.15.0/Makefile
+===================================================================
+--- shotwell-0.15.0.orig/Makefile 2013-10-13 09:51:58.893357001 +0200
++++ shotwell-0.15.0/Makefile 2013-10-13 09:54:33.885361749 +0200
+@@ -27,7 +27,7 @@
+
+ -include configure.mk
+ ifndef LIBEXECDIR
+-LIBEXECDIR=$(PREFIX)/libexec/shotwell
++LIBEXECDIR=$(PREFIX)/share/shotwell
+ endif
+
+ CORE_SUPPORTED_LANGUAGES=$(shell cat po/LINGUAS)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..2535d18
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+hardening.patch
+libexec.patch