summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 1 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 6b9f82f..a64e2c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,6 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
CHDATE:=$(shell dpkg-parsechangelog --show-field=Date)
-B_DATE:=$(shell date -d "$(CHDATE)")
%:
dh $@
@@ -21,8 +20,7 @@ override_dh_install:
mkdir -p debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
find -type f -name '*.c' -exec cp --parent '{}' debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source/ ';'
cd debian/shotwell-dbg/usr/share/doc/shotwell-dbg && \
- find . -newermt '$(B_DATE)' -print0 | xargs -0r touch --no-dereference --date='$(B_DATE)' && \
- tar --mtime="$(B_DATE)" -cJf temp-source.tar.xz temp-source
+ tar --mtime="$(CHDATE)" -cJf temp-source.tar.xz temp-source
rm -fr debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
override_dh_installchangelogs: