summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e8ca0d5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
+%:
+ dh $@ --buildsystem=meson --with gnome
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libexec=/usr/libexec \
+ -Dunity-support=true $(APPORT)
+
+override_dh_gnome_clean:
+ dh_gnome_clean --no-control
+
+override_dh_install:
+ dh_install
+ # Remove unwanted la files
+ rm -f debian/shotwell/usr/lib/*/shotwell/plugins/builtin/*.la
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.a
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.la