summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..3bdd2ba
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+
+CHDATE:=$(shell dpkg-parsechangelog --show-field=Date)
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ ./configure --prefix=/usr --libexec=/usr/lib --disable-schemas-compile
+
+override_dh_install:
+ dh_install
+ # Touch the generated C files with mtime of debian/changelog,
+ # find -type f -name '*.c' -exec touch -r $(CURDIR)/debian/changelog {} \;
+ # then install these C files required for debugging into the shotwell-dbg package.
+ mkdir -p debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
+ find -type f -name '*.c' -exec cp --parent '{}' debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source/ ';'
+ cd debian/shotwell-dbg/usr/share/doc/shotwell-dbg && \
+ tar --mtime="$(CHDATE)" -cJf temp-source.tar.xz temp-source
+ rm -fr debian/shotwell-dbg/usr/share/doc/shotwell-dbg/temp-source
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS
+
+override_dh_strip:
+ dh_strip --dbg-package=shotwell-dbg
+
+override_dh_compress:
+ dh_compress -X.tar.xz