summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index acbfebd..a772218 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,13 +4,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+#Enable the apport option when building of Ubuntu
+ifeq ($(shell dpkg-vendor --derives-from Ubuntu && echo yes),yes)
+ APPORT = -Dinstall-apport-hook=true
+endif
+
%:
dh $@ --buildsystem=meson --with gnome
override_dh_auto_configure:
dh_auto_configure -- \
--libexec=/usr/libexec \
- -Dunity-support=true
+ -Dunity-support=true $(APPORT)
override_dh_gnome_clean:
dh_gnome_clean --no-control