summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8eaecd6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+export VALAFLAGS:=$(foreach w,$(CPPFLAGS) $(CFLAGS) $(LDFLAGS),-X $(w))
+
+%:
+ dh $@ --buildsystem=meson --with gnome
+
+override_dh_gnome_clean:
+ dh_gnome_clean --no-control
+
+override_dh_install:
+ dh_install
+ # Remove unwanted la files
+ rm -f debian/shotwell/usr/lib/*/shotwell/plugins/builtin/*.la
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.a
+ rm -f debian/shotwell/usr/lib/*/*shotwell*.la