summaryrefslogtreecommitdiff
path: root/dist/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dist/debian/rules')
-rwxr-xr-xdist/debian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/dist/debian/rules b/dist/debian/rules
new file mode 100755
index 0000000..0d1d5a6
--- /dev/null
+++ b/dist/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --parallel --with gnome --buildsystem=meson
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libexec=/usr/lib \
+ -Dunity-support=true \
+ -Dinstall-apport-hook=true
+
+override_dh_gnome_clean:
+ dh_gnome_clean --no-control
+