summaryrefslogtreecommitdiff
path: root/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'misc/Makefile.am')
-rw-r--r--misc/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/misc/Makefile.am b/misc/Makefile.am
new file mode 100644
index 0000000..6376879
--- /dev/null
+++ b/misc/Makefile.am
@@ -0,0 +1,32 @@
+gsettings_SCHEMAS = \
+ org.yorba.shotwell.gschema.xml \
+ org.yorba.shotwell-extras.gschema.xml
+
+appdata_in_files = $(srcdir)/shotwell.appdata.xml.in
+appdata_XML = \
+ shotwell.appdata.xml
+
+desktopdir = $(datadir)/applications
+desktop_DATA = shotwell.desktop shotwell-viewer.desktop
+
+$(appdata_XML) : $(appdata_in_files)
+ $(AM_V_GEN) $(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+
+%.desktop.in : %.desktop.in.in
+ $(AM_V_GEN) sed -e 's|@VERSION[@]|$(VERSION)|g' $< > $@
+
+%.desktop : %.desktop.in
+ $(AM_V_GEN) $(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
+@GSETTINGS_RULES@
+@APPDATA_XML_RULES@
+
+CLEANFILES = $(appdata_XML) $(desktop_DATA) $(desktop_in_files)
+
+dist_noinst_DATA = \
+ $(srcdir)/shotwell.desktop.in.in \
+ $(srcdir)/shotwell-viewer.desktop.in.in \
+ $(gsettings_SCHEMAS) \
+ $(appdata_in_files)
+
+-include $(top_srcdir)/git.mk