summaryrefslogtreecommitdiff
path: root/misc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'misc/meson.build')
-rw-r--r--misc/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/meson.build b/misc/meson.build
new file mode 100644
index 0000000..664ddb0
--- /dev/null
+++ b/misc/meson.build
@@ -0,0 +1,28 @@
+podir = join_paths('..', 'po')
+
+i18n.merge_file(input : 'shotwell.appdata.xml.in',
+ output : 'shotwell.appdata.xml',
+ po_dir : join_paths('..', 'po'),
+ type : 'xml',
+ install: true,
+ install_dir : join_paths(get_option('datadir'), 'metainfo'))
+
+i18n.merge_file(input : 'shotwell.desktop.in',
+ output: 'shotwell.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+i18n.merge_file(input : 'shotwell-viewer.desktop.in',
+ output: 'shotwell-viewer.desktop',
+ po_dir : podir,
+ type : 'desktop',
+ install : true,
+ install_dir : join_paths(get_option('datadir'), 'applications'))
+
+install_data(['org.yorba.shotwell-extras.gschema.xml',
+ 'org.yorba.shotwell.gschema.xml'],
+ install_dir : join_paths(get_option('datadir'), 'glib-2.0', 'schemas'))
+
+gnome.compile_schemas()