summaryrefslogtreecommitdiff
path: root/plugins/authenticator/shotwell/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/authenticator/shotwell/meson.build')
-rw-r--r--plugins/authenticator/shotwell/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/authenticator/shotwell/meson.build b/plugins/authenticator/shotwell/meson.build
new file mode 100644
index 0000000..4404242
--- /dev/null
+++ b/plugins/authenticator/shotwell/meson.build
@@ -0,0 +1,28 @@
+authenticator_shotwell_sources = [
+ 'ShotwellAuthenticatorFactory.vala',
+ 'FacebookPublishingAuthenticator.vala',
+ 'FlickrPublishingAuthenticator.vala',
+ 'GoogleAuthenticator.vala',
+ 'OAuth1Authenticator.vala',
+ 'TumblrAuthenticator.vala'
+ ]
+
+authenticator_shotwell_resources = gnome.compile_resources('authenticator-resource',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml',
+ source_dir : meson.source_root())
+
+authenticator_shotwell_deps = [gee, gtk, gio, soup, json_glib, sw_plugin,
+ sw_plugin_common_dep, json_glib, xml, webkit]
+
+authenticator = library('shotwell-authenticator',
+ authenticator_shotwell_sources + authenticator_shotwell_resources,
+ dependencies : authenticator_shotwell_deps,
+ include_directories : config_incdir,
+ version: meson.project_version(),
+ vala_args : ['--gresources',
+ 'org.gnome.Shotwell.Authenticator.gresource.xml'],
+ c_args :
+ '-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Authenticator"',
+ install: true)
+authenticator_dep = declare_dependency(include_directories : include_directories('.'),
+ link_with : authenticator)