summaryrefslogtreecommitdiff
path: root/plugins/shotwell-data-imports/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shotwell-data-imports/Makefile')
-rw-r--r--plugins/shotwell-data-imports/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/plugins/shotwell-data-imports/Makefile b/plugins/shotwell-data-imports/Makefile
new file mode 100644
index 0000000..52329e7
--- /dev/null
+++ b/plugins/shotwell-data-imports/Makefile
@@ -0,0 +1,30 @@
+
+PLUGIN := shotwell-data-imports
+
+PLUGIN_PKGS := \
+ gtk+-3.0 \
+ gexiv2 \
+ gee-0.8 \
+ sqlite3
+
+SRC_FILES := \
+ shotwell-data-imports.vala \
+ ../common/VersionNumber.vala \
+ ../common/SqliteSupport.vala \
+ FSpotImporter.vala \
+ FSpotDatabaseBehavior.vala \
+ FSpotDatabase.vala \
+ FSpotDatabaseTable.vala \
+ FSpotTableBehavior.vala \
+ FSpotMetaTable.vala \
+ FSpotPhotosTable.vala \
+ FSpotPhotoTagsTable.vala \
+ FSpotPhotoVersionsTable.vala \
+ FSpotRollsTable.vala \
+ FSpotTagsTable.vala
+
+RC_FILES := \
+ f-spot-24.png
+
+include ../Makefile.plugin.mk
+