summaryrefslogtreecommitdiff
path: root/plugins/shotwell-publishing-extras/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shotwell-publishing-extras/meson.build')
-rw-r--r--plugins/shotwell-publishing-extras/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/shotwell-publishing-extras/meson.build b/plugins/shotwell-publishing-extras/meson.build
new file mode 100644
index 0000000..34f3e12
--- /dev/null
+++ b/plugins/shotwell-publishing-extras/meson.build
@@ -0,0 +1,21 @@
+shotwell_publishing_extra_sources = [
+ 'GalleryConnector.vala',
+ 'RajcePublishing.vala',
+ 'shotwell-publishing-extras.vala',
+ 'YandexPublishing.vala'
+ ]
+
+shotwell_publishing_extra_resources = gnome.compile_resources('publishing-extra-resource',
+ 'org.gnome.Shotwell.Publishing.Extras.gresource.xml')
+
+shared_module('shotwell-publishing-extras',
+ shotwell_publishing_extra_sources + shotwell_publishing_extra_resources,
+ dependencies : [gee, gtk, xml, soup, gdk_pixbuf, sw_plugin,
+ sw_plugin_common_dep, json_glib, webkit],
+ vala_args : [
+ '--gresources', 'org.gnome.Shotwell.Publishing.Extras.gresource.xml'
+ ],
+ c_args : ['-DPLUGIN_RESOURCE_PATH="/org/gnome/Shotwell/Publishing/Extras"',
+ '-DGCR_API_SUBJECT_TO_CHANGE'],
+ install: true,
+ install_dir : shotwell_plugin_dir)