summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index e252a82..530d6af 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -32,7 +32,7 @@ endif
shotwell_deps = [gio, gee, sqlite, gtk, sqlite, posix, gphoto2,
gstreamer_pbu, gio_unix, gudev, gexiv2, gmodule,
- libraw, libexif, sw_plugin]
+ libraw, libexif, sw_plugin, gdk, version]
if unity_available
shotwell_deps += [unity]
endif
@@ -197,6 +197,7 @@ executable('shotwell',
'MediaPage.vala',
'MediaDataRepresentation.vala',
'DesktopIntegration.vala',
+ 'Portal.vala',
'MediaInterfaces.vala',
'MediaMetadata.vala',
'VideoMetadata.vala',
@@ -244,6 +245,7 @@ executable('shotwell',
vala_args : ['--pkg', 'libgphoto2',
'--pkg', 'libraw',
'--pkg', 'libexif',
+ '--pkg', 'version',
'--gresources',
join_paths(meson.source_root(),
'org.gnome.Shotwell.gresource.xml')