summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index de1f012..5319cfc 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -2,4 +2,24 @@ natural_collate_test = executable('natural-collate-test',
['NaturalCollate-Test.vala', 'NaturalCollate.vala'],
dependencies : gio)
+jfif_support_test = executable('jfif-support-test',
+ ['jfif/JfifSupport-Test.vala',
+ 'jfif/PhotoFileSniffer.vala',
+ 'jfif/PhotoFileAdapter.vala',
+ 'jfif/JfifSupport.vala',
+ 'jfif/GdkSupport.vala',
+ 'jfif/Dimensions.vala',
+ 'jfif/string.vala',
+ 'jfif/file.vala',
+ 'jfif/util_core-stub.vala',
+ 'jfif/ProgressMonitor-stub.vala',
+ 'jfif/PhotoMetadata-stub.vala',
+ 'jfif/PhotoFileFormat-jfifstub.vala',
+ 'jfif/util_image-stub.vala'],
+ dependencies : [gio, gee, gtk, gexiv2, math],
+ c_args : ['-DTEST_DATA_DIR="@0@"'.format(meson.current_source_dir())]
+ )
+
+
test('natural-collate', natural_collate_test)
+test('jfif-support', jfif_support_test)