summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2010-09-17 19:45:40 +0200
committerAlessio Treglia <alessio@debian.org>2010-09-17 19:45:40 +0200
commit538a1b360ca3153d4b7a57f6e71bb7dd06caa638 (patch)
tree79219dddb8e736f62875deeb59cc8fde050c7d0b
parent888bee35ecceab1ecc104e483fd42dad6bf060d1 (diff)
Switch back to format 1.0
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules18
-rw-r--r--debian/source/format2
3 files changed, 20 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index da003af..4409d16 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,8 @@ Priority: optional
Maintainer: Alessio Treglia <alessio@debian.org>
Standards-Version: 3.9.1
Build-Depends: debhelper (>= 7.0.50~),
+ quilt (>= 0.46-7~),
+ lsb-release,
gnome-pkg-tools (>= 0.10),
gnome-doc-utils (>= 0.3.2),
gnome-common,
diff --git a/debian/rules b/debian/rules
index 76a786f..a781c17 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,25 @@
#!/usr/bin/make -f
+DISTRIBUTION = $(shell lsb_release -i | cut -f2 -d':' | tr -d '\t')
LDFLAGS+=-Wl,--as-needed
%:
- dh $@
+ dh $@ --with=quilt
+
+override_dh_quilt_unpatch:
+ dh_quilt_unpatch
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ if test -e debian/patches/series.old; then \
+ mv debian/patches/series.old debian/patches/series ;\
+ fi
+endif
+
+override_dh_quilt_patch:
+ifeq ("$(DISTRIBUTION)", "Ubuntu")
+ cp debian/patches/series debian/patches/series.old
+ echo 20-lpi.patch >> debian/patches/series
+endif
+ dh_quilt_patch
# Fixes FTBFS
override_dh_auto_test:
diff --git a/debian/source/format b/debian/source/format
index 163aaf8..d3827e7 100644
--- a/debian/source/format
+++ b/debian/source/format
@@ -1 +1 @@
-3.0 (quilt)
+1.0