summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-11 16:29:45 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-04-11 16:29:45 +0200
commitf29bda377aa09a0c61064075022879e8260eda35 (patch)
treee6e841e0d588c5c81359a0664e21c01c4aa1ec10
parent0855244f7ae75d89788c88015cca9c08fad3f39f (diff)
Add new parts add debian/simple-scan.bug-script
-rw-r--r--debian/changelog17
-rw-r--r--debian/simple-scan.bug-script35
2 files changed, 48 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index d485002..93c9911 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,24 @@
+simple-scan (3.16.0.1-1) unstable; urgency=low
+
+ * New upstream release.
+ - Fix invalid po/Makefile.in.in.
+ * debian/simple-scan.bug-script:
+ - Add a user query to include data to the bug report.
+ - Add lsusb -v to get the usb hardware.
+ - Add scanimage -L to get all detected sanners.
+ - Replace ~/ with /home/${USER}/ to find the local log file.
+
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sat, 11 Apr 2015 13:00:47 +0200
+
simple-scan (3.15.91-1) unstable; urgency=low
* New upstream release.
- Update translations.
- Don't use GtkHeaderBar in LXDE, MATE (Closes: #756913).
- * Rewrite license text at debian/copyright.
+ * Rewrite license text in debian/copyright.
* debian/control:
- - Add python-rsvg to Build-Depends to compare SVG images at build time.
+ - Add python-rsvg to Build-Depends in order to compare SVG files
+ before and after being optimized with dh_scour during build.
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 08 Mar 2015 11:52:36 +0100
diff --git a/debian/simple-scan.bug-script b/debian/simple-scan.bug-script
index 1de7951..ddfbfcf 100644
--- a/debian/simple-scan.bug-script
+++ b/debian/simple-scan.bug-script
@@ -1,7 +1,25 @@
#!/bin/bash
+cat <<EOF
+
+Providing additional information can help diagnose problems with simple-scan.
+Specifically, this would include:
+- Your personal simple-scan log file.
+- The list of your usb devices.
+- A list of detected scanners.
+
+If this information is not relevant for your bug report or you have privacy
+concerns, please choose no.
+
+EOF
+
+yesno "Do you want to provide additional information [Y|n]? " yep
+[ "$REPLY" = yep ] || exit 0
+
+
REPORTBUG_VERSION=$(dpkg-query -f '${source:Version}' -W reportbug)
-LOG_FILE='~/.cache/simple-scan/simple-scan.log'
+#LOG_FILE="~/.cache/simple-scan/simple-scan.log"
+LOG_FILE="/home/${USER}/.cache/simple-scan/simple-scan.log"
# Depending on whether reportbug is new enough, we either write the output of
# our various commands to a file and attach them to the report (this needs
@@ -21,8 +39,21 @@ if dpkg --compare-versions "$REPORTBUG_VERSION" ge "6.5.0"; then
#
if [ -f ${LOG_FILE} ]; then
cat ${LOG_FILE} >$DIR/logfile.user
- echo $DIR/logfile.user >&3
+ echo "$DIR/logfile.user" >&3
fi
+ #
+ # scanimage -L
+ #
+ scanimage -L >$DIR/scanimage.user
+ echo "$DIR/scanimage.user" >&3
+
+ #
+ # lsusb
+ #
+ lsusb -v >$DIR/lsusb.user
+ echo "$DIR/lsusb.user" >&3
+
+
echo "-- END ATTACHMENTS --" >&3
fi