summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessio Treglia <alessio@debian.org>2011-08-27 11:00:53 +0200
committerAlessio Treglia <alessio@debian.org>2011-08-27 11:00:53 +0200
commit183a72b2afa6118d9b1e7a5a56588247d59457c7 (patch)
tree223bdd05de830f83c2bdb09c47ceb8a9e5e5f944
parent744780a703ff921ff5fd2f3ba227eef18112c117 (diff)
Refresh 20-lpi.patch
-rw-r--r--debian/patches/20-lpi.patch54
1 files changed, 28 insertions, 26 deletions
diff --git a/debian/patches/20-lpi.patch b/debian/patches/20-lpi.patch
index 237803a..ca85979 100644
--- a/debian/patches/20-lpi.patch
+++ b/debian/patches/20-lpi.patch
@@ -1,38 +1,40 @@
Origin: Ubuntu
Description: Add launchpad-integration support.
---
- configure.ac | 1 +
- src/ui.c | 5 +++++
- 2 files changed, 6 insertions(+)
+ configure.ac | 1 +
+ src/Makefile.am | 1 +
+ src/ui.vala | 3 +++
+ 3 files changed, 5 insertions(+)
--- simple-scan.orig/configure.ac
+++ simple-scan/configure.ac
-@@ -36,6 +36,7 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
- cairo-pdf
- dbus-glib-1
+@@ -32,6 +32,7 @@ PKG_CHECK_MODULES(SIMPLE_SCAN, [
+ cairo
+ gdk-pixbuf-2.0
gudev-1.0
-+ launchpad-integration
++ launchpad-integration-3.0
])
- AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
---- simple-scan.orig/src/ui.c
-+++ simple-scan/src/ui.c
-@@ -16,6 +16,7 @@
- #include <gconf/gconf-client.h>
- #include <math.h>
- #include <unistd.h> // TEMP: Needed for close() in get_temporary_filename()
-+#include <launchpad-integration.h>
+ PKG_CHECK_MODULES(COLORD, [
+--- simple-scan.orig/src/Makefile.am
++++ simple-scan/src/Makefile.am
+@@ -15,6 +15,7 @@ simple_scan_SOURCES = \
- #include "ui.h"
- #include "book-view.h"
-@@ -1581,6 +1582,10 @@ ui_load (SimpleScan *ui)
- }
- gtk_builder_connect_signals (builder, ui);
+ simple_scan_VALAFLAGS = \
+ --pkg=zlib \
++ --pkg=launchpad-integration-3.0 \
+ --pkg=gudev-1.0 \
+ --pkg=gio-2.0 \
+ --pkg=gtk+-3.0
+--- simple-scan.orig/src/ui.vala
++++ simple-scan/src/ui.vala
+@@ -1267,6 +1267,9 @@ public class SimpleScan
+ }
+ builder.connect_signals (this);
-+ /* Add Launchpad integration */
-+ launchpad_integration_set_sourcepackagename ("simple-scan");
-+ launchpad_integration_add_items (GTK_WIDGET (gtk_builder_get_object (builder, "help_menu")), 1, TRUE, TRUE);
++ LaunchpadIntegration.set_sourcepackagename ("simple-scan");
++ LaunchpadIntegration.add_items ((Gtk.Widget) builder.get_object ("help_menu"), 1, true, true);
+
- ui->priv->window = GTK_WIDGET (gtk_builder_get_object (builder, "simple_scan_window"));
- ui->priv->main_vbox = GTK_WIDGET (gtk_builder_get_object (builder, "main_vbox"));
- ui->priv->page_move_left_menuitem = GTK_WIDGET (gtk_builder_get_object (builder, "page_move_left_menuitem"));
+ window = (Gtk.Window) builder.get_object ("simple_scan_window");
+ main_vbox = (Gtk.VBox) builder.get_object ("main_vbox");
+ page_move_left_menuitem = (Gtk.MenuItem) builder.get_object ("page_move_left_menuitem");