summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-11-12 13:21:19 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-11-12 13:21:19 +0100
commit99656b4fb34c8a8c6a174c7953a6b218ba6568c6 (patch)
treef511703bdeeff064dbc314281c6abce9b0bb5348 /autogen.sh
parent6c629d45711b613257d30e8d5a1527003d9c3f1f (diff)
parent35fd3ab8990210defe10f1614abe4ca1afe04c5d (diff)
Merge branch 'feature/upstream' into develop
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh35
1 files changed, 0 insertions, 35 deletions
diff --git a/autogen.sh b/autogen.sh
deleted file mode 100755
index aaf9fdb..0000000
--- a/autogen.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-# Run this to generate all the initial makefiles, etc.
-srcdir=`dirname $0`
-test -z "$srcdir" && srcdir=.
-
-(test -f $srcdir/configure.ac) || {
- echo "**Error**: Directory "\`$srcdir\'" does not look like the top-level project directory"
- exit 1
-}
-
-PKG_NAME=`autoconf --trace 'AC_INIT:$1' "$srcdir/configure.ac"`
-
-if [ "$#" = 0 -a "x$NOCONFIGURE" = "x" ]; then
- echo "**Warning**: I am going to run \`configure' with no arguments." >&2
- echo "If you wish to pass any to it, please specify them on the" >&2
- echo \`$0\'" command line." >&2
- echo "" >&2
-fi
-
-set -x
-aclocal --install || exit 1
-autoreconf --verbose --force --install -Wno-portability || exit 1
-{ set +x; } 2>/dev/null
-
-if [ "$NOCONFIGURE" = "" ]; then
- set -x
- $srcdir/configure "$@" || exit 1
- { set +x; } 2>/dev/null
-
- if [ "$1" = "--help" ]; then exit 0 else
- echo "Now type \`make\' to compile $PKG_NAME" || exit 1
- fi
-else
- echo "Skipping configure process."
-fi