summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-03 12:10:16 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-03 12:10:16 +0100
commit80718a1e12c6eb5429ae84c1d7e78f9bb4a19b14 (patch)
treec1020bc5de633078799942fdee4d8edda245d158 /src/Makefile.am
parent3b7526f55295d8cf84a954145ee60d98c62c5111 (diff)
parent02cc3d8088c307a26f9b52e294fb932d1e40ee4d (diff)
Merge tag 'upstream/3.19.1'
Upstream version 3.19.1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8bfb480..569f739 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,10 +33,15 @@ if HAVE_COLORD
simple_scan_VALAFLAGS += -D HAVE_COLORD
endif
+if HAVE_PACKAGEKIT
+simple_scan_VALAFLAGS += -D HAVE_PACKAGEKIT
+endif
+
simple_scan_CFLAGS = \
-w \
$(SIMPLE_SCAN_CFLAGS) \
$(COLORD_CFLAGS) \
+ $(PACKAGEKIT_CFLAGS) \
$(WARN_CFLAGS) \
-DVERSION=\"$(VERSION)\" \
-DGETTEXT_PACKAGE=\"$(GETTEXT_PACKAGE)\" \
@@ -50,6 +55,7 @@ simple_scan_CFLAGS = \
simple_scan_LDADD = \
$(SIMPLE_SCAN_LIBS) \
$(COLORD_LIBS) \
+ $(PACKAGEKIT_LIBS) \
-lsane \
-lm