summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0005-zlib.patch28
-rw-r--r--debian/patches/0100-typos.patch18
-rw-r--r--debian/patches/series2
3 files changed, 48 insertions, 0 deletions
diff --git a/debian/patches/0005-zlib.patch b/debian/patches/0005-zlib.patch
new file mode 100644
index 0000000..0fda723
--- /dev/null
+++ b/debian/patches/0005-zlib.patch
@@ -0,0 +1,28 @@
+Description: add zlib
+Last-Update: 2015-01-19
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -71,6 +71,7 @@ AM_CONDITIONAL(HAVE_PACKAGEKIT, test $ha
+
+ AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
+ AC_CHECK_HEADERS([sane/saneopts.h],[],[AC_MSG_ERROR([SANE not found])])
++AC_CHECK_HEADERS([zlib.h],[],[AC_MSG_ERROR([ZLib not found])])
+
+ dnl ###########################################################################
+ dnl Documentation
+Index: trunk/src/Makefile.am
+===================================================================
+--- trunk.orig/src/Makefile.am
++++ trunk/src/Makefile.am
+@@ -57,6 +57,7 @@ simple_scan_LDADD = \
+ $(COLORD_LIBS) \
+ $(PACKAGEKIT_LIBS) \
+ -lsane \
++ -lz \
+ -lm
+
+ CLEANFILES = \
diff --git a/debian/patches/0100-typos.patch b/debian/patches/0100-typos.patch
new file mode 100644
index 0000000..0f63a81
--- /dev/null
+++ b/debian/patches/0100-typos.patch
@@ -0,0 +1,18 @@
+Description: Typos
+Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
+Last-Update: 206-04-10
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/src/autosave-manager.vala
+===================================================================
+--- trunk.orig/src/autosave-manager.vala
++++ trunk/src/autosave-manager.vala
+@@ -74,7 +74,7 @@ public class AutosaveManager
+ catch (Error e)
+ {
+ if (!(e is FileError.NOENT))
+- warning ("Could not load autosave infomation; not restoring any autosaves: %s", e.message);
++ warning ("Could not load autosave information; not restoring any autosaves: %s", e.message);
+ return;
+ }
+ var pages = get_value (file, "simple-scan", "pages");
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..74172d5
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+#0100-typos.patch
+0005-zlib.patch