summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 8 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 67fa7e8..7abb6da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,17 +8,21 @@ export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
LDFLAGS+=-Wl,--as-needed
%:
- dh $@ --with scour
+ dh $@ --with=autoreconf,scour
# Fixes FTBFS
override_dh_auto_test:
# Autoreconf due to 01_lpi.patch
-override_dh_auto_configure:
+override_dh_autoreconf:
[ -e gnome-doc-utils.make ] || \
ln -s /usr/share/gnome-doc-utils/gnome-doc-utils.make
- autoreconf -f -i -s
- dh_auto_configure
+ dh_autoreconf
+
+override_dh_auto_clean:
+ dh_auto_clean
+ [ ! -h gnome-doc-utils.make ] || \
+ rm gnome-doc-utils.make
override_dh_auto_build:
cd po; intltool-update -p