summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhsoting.net>2019-04-28 20:10:31 +0200
committerJörg Frings-Fürst <debian@jff-webhsoting.net>2019-04-28 20:10:31 +0200
commitcb602bce7004aedcad88f5a22e4d6acd9372da8f (patch)
tree280b7145431f62a4174e2488b426f0d0b1ea2014
parent61de3962c8cff89337eb812356d634ea96fd0031 (diff)
Some work to fix build errors
-rw-r--r--debian/control4
-rw-r--r--debian/patches/0001-missing_pthread.patch13
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
4 files changed, 20 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 5de9921..d5658ca 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,10 @@ Section: libs
Priority: optional
Maintainer: Jörg Frings-Fürst <debian@jff.email>
Build-Depends:
+ cmake,
debhelper (>= 11),
- dh-exec (>=0.3)
+ dh-exec (>=0.3),
+ libgtest-dev
Build-Depends-Indep:
doxygen,
graphviz,
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
new file mode 100644
index 0000000..3054ce9
--- /dev/null
+++ b/debian/patches/0001-missing_pthread.patch
@@ -0,0 +1,13 @@
+Index: trunk/CMakeLists.txt
+===================================================================
+--- trunk.orig/CMakeLists.txt
++++ trunk/CMakeLists.txt
+@@ -209,7 +209,7 @@ if(URIPARSER_BUILD_TOOLS)
+ tool/uriparse.c
+ )
+
+- target_link_libraries(uriparse PUBLIC uriparser)
++ target_link_libraries(uriparse PUBLIC uriparser pthread)
+
+ if(HAIKU)
+ # Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..39a7230
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-missing_pthread.patch
diff --git a/debian/rules b/debian/rules
index 3245017..0639e27 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,7 +25,9 @@ endif
dh $@ --with autoreconf
override_dh_auto_configure:
- ./configure $(confflags)
+ dh_auto_configure --buildsystem=cmake
+#$(confflags)
+# ./configure $(confflags)
override_dh_auto_build-indep:
dh_auto_build