summaryrefslogtreecommitdiff
path: root/debian/patches/0001-missing_pthread.patch
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhsoting.net>2019-07-20 08:53:35 +0200
committerJörg Frings-Fürst <debian@jff-webhsoting.net>2019-07-20 08:53:35 +0200
commit63e6ffd8dd8412282e1beccb9a01e33aa57c13f0 (patch)
treef489a0246d74ed4b63c39eff4e6c72f9d5bd862a /debian/patches/0001-missing_pthread.patch
parentd289e0569e0317ffd228d8d0bf9f4a7a7a4fc41c (diff)
parent1bd65df2de001b173a8d6a08397043225ad115ad (diff)
Merge branch 'release/debian/0.9.3-1'debian/0.9.3-1
Diffstat (limited to 'debian/patches/0001-missing_pthread.patch')
-rw-r--r--debian/patches/0001-missing_pthread.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
new file mode 100644
index 0000000..1567ac4
--- /dev/null
+++ b/debian/patches/0001-missing_pthread.patch
@@ -0,0 +1,36 @@
+Description: Add missing pthread to build system
+Author: Jörg Frings-Fürst <debian@jff.email>
+Last-Update: 2019-07-13
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/CMakeLists.txt
+===================================================================
+--- trunk.orig/CMakeLists.txt
++++ trunk/CMakeLists.txt
+@@ -212,7 +212,8 @@ if(URIPARSER_BUILD_TOOLS)
+ tool/uriparse.c
+ )
+
+- target_link_libraries(uriparse PUBLIC uriparser)
++ find_package(Threads REQUIRED)
++ target_link_libraries(uriparse PUBLIC uriparser pthread)
+
+ if(HAIKU)
+ # Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
+@@ -245,6 +246,7 @@ if(URIPARSER_BUILD_TESTS)
+ enable_testing()
+
+ find_package(GTest 1.8.1 REQUIRED)
++ find_package(Threads REQUIRED)
+
+ add_executable(testrunner
+ test/FourSuite.cpp
+@@ -274,7 +276,7 @@ if(URIPARSER_BUILD_TESTS)
+ )
+
+ target_link_libraries(testrunner PUBLIC
+- ${GTEST_BOTH_LIBRARIES}
++ ${GTEST_BOTH_LIBRARIES} pthread
+ )
+
+ add_test(