summaryrefslogtreecommitdiff
path: root/debian/patches/0001-missing_pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-missing_pthread.patch')
-rw-r--r--debian/patches/0001-missing_pthread.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
new file mode 100644
index 0000000..3054ce9
--- /dev/null
+++ b/debian/patches/0001-missing_pthread.patch
@@ -0,0 +1,13 @@
+Index: trunk/CMakeLists.txt
+===================================================================
+--- trunk.orig/CMakeLists.txt
++++ trunk/CMakeLists.txt
+@@ -209,7 +209,7 @@ if(URIPARSER_BUILD_TOOLS)
+ tool/uriparse.c
+ )
+
+- target_link_libraries(uriparse PUBLIC uriparser)
++ target_link_libraries(uriparse PUBLIC uriparser pthread)
+
+ if(HAIKU)
+ # Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)