summaryrefslogtreecommitdiff
path: root/debian/patches/0001-missing_pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-missing_pthread.patch')
-rw-r--r--debian/patches/0001-missing_pthread.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
index a7aa3cc..0d6db5a 100644
--- a/debian/patches/0001-missing_pthread.patch
+++ b/debian/patches/0001-missing_pthread.patch
@@ -7,8 +7,8 @@ Index: trunk/CMakeLists.txt
===================================================================
--- trunk.orig/CMakeLists.txt
+++ trunk/CMakeLists.txt
-@@ -217,7 +217,8 @@ if(URIPARSER_BUILD_TOOLS)
- tool/uriparse.c
+@@ -229,7 +229,8 @@ if(URIPARSER_BUILD_TOOLS)
+ ${CMAKE_CURRENT_SOURCE_DIR}/tool/uriparse.c
)
- target_link_libraries(uriparse PUBLIC uriparser)
@@ -17,15 +17,15 @@ Index: trunk/CMakeLists.txt
if(HAIKU)
# Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
-@@ -258,6 +259,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -270,6 +271,7 @@ if(URIPARSER_BUILD_TESTS)
enable_testing()
find_package(GTest 1.8.0 REQUIRED)
+ find_package(Threads REQUIRED)
add_executable(testrunner
- test/FourSuite.cpp
-@@ -287,7 +289,7 @@ if(URIPARSER_BUILD_TESTS)
+ ${CMAKE_CURRENT_SOURCE_DIR}/test/FourSuite.cpp
+@@ -299,7 +301,7 @@ if(URIPARSER_BUILD_TESTS)
)
target_link_libraries(testrunner PUBLIC
@@ -33,4 +33,4 @@ Index: trunk/CMakeLists.txt
+ ${GTEST_BOTH_LIBRARIES} pthread
)
- add_test(
+ # NOTE: uriparser does not use pthreads itself but gtest does