summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/control3
-rw-r--r--debian/copyright2
-rw-r--r--debian/not-installed3
-rw-r--r--debian/patches/0001-missing_pthread.patch12
5 files changed, 23 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index b20ced8..3cb9c0c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+uriparser (0.9.5+dfsg-1) experimental; urgency=medium
+
+ * New upstream release:
+ - Rebase patches.
+ - Fix debain/not-installed.
+ * Declare compliance with Debian Policy 4.5.1 (No changes needed).
+ * debian/control:
+ - Remove Build-Depend dh-exec.
+ * debian/copyright:
+ - Add year 2021 to myself.
+
+ -- Jörg Frings-Fürst <debian@jff.email> Mon, 26 Apr 2021 22:19:23 +0200
+
uriparser (0.9.4+dfsg-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 784f139..91266e1 100644
--- a/debian/control
+++ b/debian/control
@@ -5,14 +5,13 @@ Maintainer: Jörg Frings-Fürst <debian@jff.email>
Build-Depends:
cmake,
debhelper-compat (= 13),
- dh-exec (>=0.3),
doxygen,
graphviz,
libgtest-dev,
libqt5sql5-sqlite,
qtbase5-dev,
qttools5-dev-tools
-Standards-Version: 4.5.0
+Standards-Version: 4.5.1
Rules-Requires-Root: no
Homepage: http://uriparser.sourceforge.net
Vcs-Git: git://jff.email/opt/git/uriparser.git
diff --git a/debian/copyright b/debian/copyright
index 7af6cb0..125ce98 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -20,7 +20,7 @@ Copyright: 2014-2015 Sebastian Pipping <webmaster@hartwork.org>
License: LGPL-2.1+
Files: debian/*
-Copyright: 2014-2020 Jörg Frings-Fürst <debian@jff.email>
+Copyright: 2014-2021 Jörg Frings-Fürst <debian@jff.email>
License: GPL-3+
License: BSD-3-clause
diff --git a/debian/not-installed b/debian/not-installed
index 3192fd7..e8aa5db 100644
--- a/debian/not-installed
+++ b/debian/not-installed
@@ -1,4 +1,5 @@
usr/share/doc/uriparser/uriparser-0.9.4.qch
usr/share/doc/uriparser/html/*
usr/bin/uriparse
-usr/lib/*/cmake/uriparser-0.9.4/*
+usr/lib/*/cmake/uriparser-0.9.5/*
+usr/lib/*/uriparser-0.9.5/uriparser.cmake
diff --git a/debian/patches/0001-missing_pthread.patch b/debian/patches/0001-missing_pthread.patch
index a7aa3cc..0d6db5a 100644
--- a/debian/patches/0001-missing_pthread.patch
+++ b/debian/patches/0001-missing_pthread.patch
@@ -7,8 +7,8 @@ Index: trunk/CMakeLists.txt
===================================================================
--- trunk.orig/CMakeLists.txt
+++ trunk/CMakeLists.txt
-@@ -217,7 +217,8 @@ if(URIPARSER_BUILD_TOOLS)
- tool/uriparse.c
+@@ -229,7 +229,8 @@ if(URIPARSER_BUILD_TOOLS)
+ ${CMAKE_CURRENT_SOURCE_DIR}/tool/uriparse.c
)
- target_link_libraries(uriparse PUBLIC uriparser)
@@ -17,15 +17,15 @@ Index: trunk/CMakeLists.txt
if(HAIKU)
# Function inet_ntop needs -lsocket or -lnetwork (see pull request #45)
-@@ -258,6 +259,7 @@ if(URIPARSER_BUILD_TESTS)
+@@ -270,6 +271,7 @@ if(URIPARSER_BUILD_TESTS)
enable_testing()
find_package(GTest 1.8.0 REQUIRED)
+ find_package(Threads REQUIRED)
add_executable(testrunner
- test/FourSuite.cpp
-@@ -287,7 +289,7 @@ if(URIPARSER_BUILD_TESTS)
+ ${CMAKE_CURRENT_SOURCE_DIR}/test/FourSuite.cpp
+@@ -299,7 +301,7 @@ if(URIPARSER_BUILD_TESTS)
)
target_link_libraries(testrunner PUBLIC
@@ -33,4 +33,4 @@ Index: trunk/CMakeLists.txt
+ ${GTEST_BOTH_LIBRARIES} pthread
)
- add_test(
+ # NOTE: uriparser does not use pthreads itself but gtest does