summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..5814a0c
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,34 @@
+## Build doc files
+all-local: html/index.html
+
+html/index.html: $(srcdir)/../include/uriparser/*.h \
+ $(srcdir)/../src/*.c \
+ $(srcdir)/../src/*.h \
+ $(srcdir)/Mainpage
+ rm -Rf "$(builddir)/html"
+ doxygen Doxyfile
+ touch html/index.html
+
+
+## Clean doc files
+clean-local:
+ rm -Rf "$(builddir)/html"
+ rm -f *.qch
+
+
+## Clean configure files
+distclean-local:
+ rm -f config.{log,status} release.sh Doxyfile
+
+
+## Install doc files
+install-data-local:
+ $(MKDIR_P) "$(DESTDIR)$(docdir)/html" ## Didn't work with installdirs-local
+ $(INSTALL_DATA) html/*.{css,html,png} "$(DESTDIR)$(docdir)/html/"
+ -$(INSTALL_DATA) *.qch "$(DESTDIR)$(docdir)/"
+
+
+## Uninstall doc files
+uninstall-local:
+ rm -Rf "$(DESTDIR)$(docdir)/html"
+ rm -f "$(DESTDIR)$(docdir)"/*.qch