summaryrefslogtreecommitdiff
path: root/win32
diff options
context:
space:
mode:
Diffstat (limited to 'win32')
-rw-r--r--win32/Code_Blocks/test.cbp23
-rw-r--r--win32/MinGW/Makefile4
-rw-r--r--win32/Visual_Studio_2005/test.vcproj100
3 files changed, 1 insertions, 126 deletions
diff --git a/win32/Code_Blocks/test.cbp b/win32/Code_Blocks/test.cbp
index 85c7ca4..ec3cb5c 100644
--- a/win32/Code_Blocks/test.cbp
+++ b/win32/Code_Blocks/test.cbp
@@ -32,30 +32,7 @@
<Unit filename="..\..\include\uriparser\UriDefsConfig.h" />
<Unit filename="..\..\include\uriparser\UriDefsUnicode.h" />
<Unit filename="..\..\include\uriparser\UriIp4.h" />
- <Unit filename="..\CppTest\collectoroutput.cpp" />
- <Unit filename="..\CppTest\compileroutput.cpp" />
- <Unit filename="..\CppTest\cpptest-assert.h" />
- <Unit filename="..\CppTest\cpptest-collectoroutput.h" />
- <Unit filename="..\CppTest\cpptest-compileroutput.h" />
- <Unit filename="..\CppTest\cpptest-htmloutput.h" />
- <Unit filename="..\CppTest\cpptest-output.h" />
- <Unit filename="..\CppTest\cpptest-source.h" />
- <Unit filename="..\CppTest\cpptest-suite.h" />
- <Unit filename="..\CppTest\cpptest-textoutput.h" />
- <Unit filename="..\CppTest\cpptest-time.h" />
- <Unit filename="..\CppTest\cpptest.h" />
- <Unit filename="..\CppTest\htmloutput.cpp" />
- <Unit filename="..\CppTest\missing.cpp" />
- <Unit filename="..\CppTest\missing.h" />
- <Unit filename="..\CppTest\source.cpp" />
- <Unit filename="..\CppTest\suite.cpp" />
- <Unit filename="..\CppTest\textoutput.cpp" />
- <Unit filename="..\CppTest\time.cpp" />
- <Unit filename="..\CppTest\utils.cpp" />
- <Unit filename="..\CppTest\utils.h" />
- <Unit filename="..\CppTest\winconfig.h" />
<Unit filename="..\..\test\FourSuite.cpp" />
- <Unit filename="..\..\test\FourSuite.h" />
<Unit filename="..\..\test\test.cpp" />
<Extensions>
<code_completion />
diff --git a/win32/MinGW/Makefile b/win32/MinGW/Makefile
index 16e361d..09d929c 100644
--- a/win32/MinGW/Makefile
+++ b/win32/MinGW/Makefile
@@ -40,7 +40,6 @@
CFLAGS = -Wall -Wextra -O3 -s
TEST_DIR = ../../test
-CPP_TEST_DIR = ../CppTest
LIB_DIR = ../../src
INCLUDE_DIR = ../../include
WIN32_DIR = ..
@@ -49,8 +48,7 @@ CXX = g++
dos = $(subst /,\,$(1))
URIPARSER_OBJECTS := $(patsubst %.c,%.o,$(wildcard $(LIB_DIR)/*.c))
-TEST_OBJECTS := $(patsubst %.cpp,%.o,$(wildcard $(CPP_TEST_DIR)/*.cpp)) \
- $(patsubst %.cpp,%.o,$(wildcard $(TEST_DIR)/*.cpp))
+TEST_OBJECTS := $(patsubst %.cpp,%.o,$(wildcard $(TEST_DIR)/*.cpp))
LIBRARY = $(WIN32_DIR)/liburiparser.a
TEST_SUITE = $(WIN32_DIR)/test.exe
diff --git a/win32/Visual_Studio_2005/test.vcproj b/win32/Visual_Studio_2005/test.vcproj
index 26086a2..4971e13 100644
--- a/win32/Visual_Studio_2005/test.vcproj
+++ b/win32/Visual_Studio_2005/test.vcproj
@@ -217,109 +217,9 @@
>
</File>
<File
- RelativePath="..\..\test\FourSuite.h"
- >
- </File>
- <File
RelativePath="..\..\test\test.cpp"
>
</File>
- <Filter
- Name="CppTest"
- >
- <File
- RelativePath="..\CppTest\collectoroutput.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\compileroutput.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\config.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-assert.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-collectoroutput.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-compileroutput.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-htmloutput.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-output.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-source.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-suite.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-textoutput.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest-time.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\cpptest.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\htmloutput.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\missing.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\missing.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\source.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\suite.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\textoutput.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\time.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\utils.cpp"
- >
- </File>
- <File
- RelativePath="..\CppTest\utils.h"
- >
- </File>
- <File
- RelativePath="..\CppTest\winconfig.h"
- >
- </File>
- </Filter>
</Filter>
</Files>
<Globals>