summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-15 15:44:27 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-15 15:44:27 +0200
commitc2c1a5fdb28acba1ca8e85f19c12fceadbc46ba9 (patch)
tree38af1161531d028f3ad9eff624fe4d311b53180c
parent1f1a4d139630a5541825f7619ac16225f67f458e (diff)
merge QA-Upload; doc-dir as sysmlink
-rw-r--r--debian/changelog19
-rw-r--r--debian/control1
-rw-r--r--debian/libxbase64-1.postinst52
-rw-r--r--debian/libxbase64-bin.install1
-rw-r--r--debian/libxbase64-bin.postinst52
-rw-r--r--debian/libxbase64-dev.install1
-rw-r--r--debian/libxbase64-dev.postinst52
-rw-r--r--debian/libxbase64-doc.docs (renamed from debian/docs)0
-rw-r--r--debian/libxbase64-doc.examples (renamed from debian/libxbase64-dev.examples)0
-rw-r--r--debian/patches/fix-types-include.diff30
-rw-r--r--debian/patches/lesserg.diff124
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/watch2
14 files changed, 263 insertions, 75 deletions
diff --git a/debian/changelog b/debian/changelog
index 85ac1db..7ff2dc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-xbase64 (3.1.2-3) unstable; urgency=low
+xbase64 (3.1.2-4) unstable; urgency=low
* New Maintainer (Closes: #756543).
* debian/copyright:
@@ -34,8 +34,23 @@ xbase64 (3.1.2-3) unstable; urgency=low
- Add some fixes for typos.
* debian/patches/fixconfig.diff
- Add fix for typo.
+ * debian/patches/*
+ - Add DEP-3 header
+ * Merge QA upload 3.1.2-3 into my work
+ * Add doc directory as symlink from libxbase64-doc
+ - Add *.postinst to save changes in the old doc dir.
- -- Jörg Frings-Fürst <debian@jff-webhosting.net> Thu, 31 Jul 2014 12:39:40 +0200
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Mon, 15 Sep 2014 15:36:21 +0200
+
+xbase64 (3.1.2-3) unstable; urgency=medium
+
+ * QA upload.
+ * Extend lesserg.diff to cover also an occurrency of "__GNU LesserC__".
+ * Fix xbtypes.h so it can be included more than one time without issues,
+ and make sure it is not included at the wrong time;
+ patch fix-types-include.diff.
+
+ -- Pino Toscano <pino@debian.org> Sat, 13 Sep 2014 11:11:18 +0200
xbase64 (3.1.2-2) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 85bafba..292cf0e 100644
--- a/debian/control
+++ b/debian/control
@@ -84,4 +84,3 @@ Description: xbase compatible C++ class library (documentation)
OS's.
.
This package contains the documentation for Xbase distributed with Xbase.
-
diff --git a/debian/libxbase64-1.postinst b/debian/libxbase64-1.postinst
new file mode 100644
index 0000000..fe67044
--- /dev/null
+++ b/debian/libxbase64-1.postinst
@@ -0,0 +1,52 @@
+#!/bin/sh
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+# source debconf library
+#. /usr/share/debconf/confmodule
+
+
+case "$1" in
+
+ configure)
+ # Replace documentation directory with symlink
+ if [ -d /usr/share/doc/libxbase64-1 ] && [ ! -L /usr/share/doc/libxbase64-1 ]; then
+ if rmdir /usr/share/doc/libxbase64-1 2>/dev/null; then
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-1
+ else
+ echo "Remove nonempty doc directory to doc/libxbase64-1.bak"
+ mv /usr/share/doc/libxbase64-1 /usr/share/doc/libxbase64-1.bak
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-1
+ fi
+ fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ exit 0
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+
+esac
+
+#DEBHELPER#
+
+
+exit 0
diff --git a/debian/libxbase64-bin.install b/debian/libxbase64-bin.install
index 0196450..423db55 100644
--- a/debian/libxbase64-bin.install
+++ b/debian/libxbase64-bin.install
@@ -9,4 +9,3 @@ usr/bin/packdbf usr/bin/
usr/bin/reindex usr/bin/
usr/bin/undelall usr/bin/
usr/bin/zap usr/bin/
-
diff --git a/debian/libxbase64-bin.postinst b/debian/libxbase64-bin.postinst
new file mode 100644
index 0000000..1333ee4
--- /dev/null
+++ b/debian/libxbase64-bin.postinst
@@ -0,0 +1,52 @@
+#!/bin/sh
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+# source debconf library
+#. /usr/share/debconf/confmodule
+
+
+case "$1" in
+
+ configure)
+ # Replace documentation directory with symlink
+ if [ -d /usr/share/doc/libxbase64-bin ] && [ ! -L /usr/share/doc/libxbase64-bin ]; then
+ if rmdir /usr/share/doc/libxbase64-bin 2>/dev/null; then
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-bin
+ else
+ echo "Remove nonempty doc directory to doc/libxbase64-bin.bak"
+ mv /usr/share/doc/libxbase64-bin /usr/share/doc/libxbase64-bin.bak
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-bin
+ fi
+ fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ exit 0
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+
+esac
+
+#DEBHELPER#
+
+
+exit 0
diff --git a/debian/libxbase64-dev.install b/debian/libxbase64-dev.install
index 67f5b76..65d3a3c 100644
--- a/debian/libxbase64-dev.install
+++ b/debian/libxbase64-dev.install
@@ -1,4 +1,3 @@
usr/include/* usr/include/
-#usr/bin/xbase64-config usr/bin/
usr/lib/*/lib*.so
usr/lib/*/lib*.a
diff --git a/debian/libxbase64-dev.postinst b/debian/libxbase64-dev.postinst
new file mode 100644
index 0000000..d684003
--- /dev/null
+++ b/debian/libxbase64-dev.postinst
@@ -0,0 +1,52 @@
+#!/bin/sh
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+# source debconf library
+#. /usr/share/debconf/confmodule
+
+
+case "$1" in
+
+ configure)
+ # Replace documentation directory with symlink
+ if [ -d /usr/share/doc/libxbase64-dev ] && [ ! -L /usr/share/doc/libxbase64-dev ]; then
+ if rmdir /usr/share/doc/libxbase64-dev 2>/dev/null; then
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-dev
+ else
+ echo "Remove nonempty doc directory to doc/libxbase64-1.bak"
+ mv /usr/share/doc/libxbase64-dev /usr/share/doc/libxbase64-dev.bak
+ ln -sf libxbase64-doc /usr/share/doc/libxbase64-dev
+ fi
+ fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ exit 0
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+
+esac
+
+#DEBHELPER#
+
+
+exit 0
diff --git a/debian/docs b/debian/libxbase64-doc.docs
index 50bd824..50bd824 100644
--- a/debian/docs
+++ b/debian/libxbase64-doc.docs
diff --git a/debian/libxbase64-dev.examples b/debian/libxbase64-doc.examples
index 7c8b6ef..7c8b6ef 100644
--- a/debian/libxbase64-dev.examples
+++ b/debian/libxbase64-doc.examples
diff --git a/debian/patches/fix-types-include.diff b/debian/patches/fix-types-include.diff
new file mode 100644
index 0000000..8643c44
--- /dev/null
+++ b/debian/patches/fix-types-include.diff
@@ -0,0 +1,30 @@
+Author: Pino Toscano <pino@debian.org>
+Description: Fix xbtypes.h usage
+ a) do not redefine xbOffT everytime xbtypes.h is included
+ b) do not include xbtypes.h in xbcdx.cpp, since it will be indirectly pulled
+ by xbase64.h
+Forwarded: no
+Last-Update: 2014-09-13
+
+--- a/xbase64/xbcdx.cpp
++++ b/xbase64/xbcdx.cpp
+@@ -1,4 +1,3 @@
+-#include "xbtypes.h"
+ #include "xbcdx.h"
+
+ xbShort xbCdx::CreateIndex(const char* filename, const char *expr,
+--- a/xbase64/xbtypes.h
++++ b/xbase64/xbtypes.h
+@@ -85,7 +85,6 @@ typedef short int xbBool;
+ #else
+ #endif
+ #endif // XB_LOCKING_ON
+-#endif // __XB_XTYPES_H__
+
+ // 64 bit file processing
+ #if defined(HAVE_FSEEKO) && defined(HAVE_FTELLO) && defined(XB_LARGEFILE_SUPPORT)
+@@ -97,3 +96,4 @@ typedef short int xbBool;
+ #define _fseek fseek
+ typedef long xbOffT;
+ #endif
++#endif // __XB_XTYPES_H__
diff --git a/debian/patches/lesserg.diff b/debian/patches/lesserg.diff
index d5d32c0..8fca28d 100644
--- a/debian/patches/lesserg.diff
+++ b/debian/patches/lesserg.diff
@@ -1,8 +1,7 @@
Description: change __GNU LesserG__ to __GNU_LesserG__
-diff -up xbase64-3.1.2/xbase64/xbase64.cpp.lesserg xbase64-3.1.2/xbase64/xbase64.cpp
---- xbase64-3.1.2/xbase64/xbase64.cpp.lesserg 2012-01-05 15:31:01.695312436 -0500
-+++ xbase64-3.1.2/xbase64/xbase64.cpp 2012-01-05 15:31:01.717312232 -0500
+--- a/xbase64/xbase64.cpp
++++ b/xbase64/xbase64.cpp
@@ -38,7 +38,7 @@
*/
@@ -12,9 +11,8 @@ diff -up xbase64-3.1.2/xbase64/xbase64.cpp.lesserg xbase64-3.1.2/xbase64/xbase64
#pragma implementation "xbase64.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbase64.h.lesserg xbase64-3.1.2/xbase64/xbase64.h
---- xbase64-3.1.2/xbase64/xbase64.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbase64.h 2012-01-05 15:31:01.718312223 -0500
+--- a/xbase64/xbase64.h
++++ b/xbase64/xbase64.h
@@ -42,7 +42,7 @@
#ifndef __XB_XBASE_H__
#define __XB_XBASE_H__
@@ -33,9 +31,17 @@ diff -up xbase64-3.1.2/xbase64/xbase64.h.lesserg xbase64-3.1.2/xbase64/xbase64.h
# ifdef XBMAKINGDLL
# define XBDLLEXPORT __declspec( dllexport )
# define XBDLLEXPORT_DATA(type) __declspec( dllexport ) type
-diff -up xbase64-3.1.2/xbase64/xbcdx.h.lesserg xbase64-3.1.2/xbase64/xbcdx.h
---- xbase64-3.1.2/xbase64/xbcdx.h.lesserg 2012-01-05 15:32:17.398608985 -0500
-+++ xbase64-3.1.2/xbase64/xbcdx.h 2012-01-05 15:32:43.051370614 -0500
+--- a/xbase64/xbcdx.h
++++ b/xbase64/xbcdx.h
+@@ -41,7 +41,7 @@ struct CdxNode
+ xbLong leftSibling;
+ xbLong rightSibling;
+ }
+-#ifdef __GNU LesserC__
++#ifdef __GNU_LesserC__
+ __attribute__((packed))
+ #endif
+ ;
@@ -50,7 +50,7 @@ struct CdxInnerNode: public CdxNode
{
char keys[500];
@@ -54,9 +60,8 @@ diff -up xbase64-3.1.2/xbase64/xbcdx.h.lesserg xbase64-3.1.2/xbase64/xbcdx.h
__attribute__((packed))
#endif
;
-diff -up xbase64-3.1.2/xbase64/xbdate.cpp.lesserg xbase64-3.1.2/xbase64/xbdate.cpp
---- xbase64-3.1.2/xbase64/xbdate.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbdate.cpp 2012-01-05 15:31:01.719312213 -0500
+--- a/xbase64/xbdate.cpp
++++ b/xbase64/xbdate.cpp
@@ -40,7 +40,7 @@
*/
@@ -66,9 +71,8 @@ diff -up xbase64-3.1.2/xbase64/xbdate.cpp.lesserg xbase64-3.1.2/xbase64/xbdate.c
#pragma implementation "xbdate.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbdate.h.lesserg xbase64-3.1.2/xbase64/xbdate.h
---- xbase64-3.1.2/xbase64/xbdate.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbdate.h 2012-01-05 15:31:01.721312195 -0500
+--- a/xbase64/xbdate.h
++++ b/xbase64/xbdate.h
@@ -45,7 +45,7 @@
#ifndef __XB_XBDATE_H__
#define __XB_XBDATE_H__
@@ -78,9 +82,8 @@ diff -up xbase64-3.1.2/xbase64/xbdate.h.lesserg xbase64-3.1.2/xbase64/xbdate.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbdbf.cpp.lesserg xbase64-3.1.2/xbase64/xbdbf.cpp
---- xbase64-3.1.2/xbase64/xbdbf.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbdbf.cpp 2012-01-05 15:31:01.722312185 -0500
+--- a/xbase64/xbdbf.cpp
++++ b/xbase64/xbdbf.cpp
@@ -39,7 +39,7 @@
*/
@@ -90,9 +93,8 @@ diff -up xbase64-3.1.2/xbase64/xbdbf.cpp.lesserg xbase64-3.1.2/xbase64/xbdbf.cpp
#pragma implementation "xbdbf.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbdbf.h.lesserg xbase64-3.1.2/xbase64/xbdbf.h
---- xbase64-3.1.2/xbase64/xbdbf.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbdbf.h 2012-01-05 15:31:01.723312175 -0500
+--- a/xbase64/xbdbf.h
++++ b/xbase64/xbdbf.h
@@ -41,7 +41,7 @@
#ifndef __XB_DBF_H__
#define __XB_DBF_H__
@@ -102,9 +104,8 @@ diff -up xbase64-3.1.2/xbase64/xbdbf.h.lesserg xbase64-3.1.2/xbase64/xbdbf.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbexp.cpp.lesserg xbase64-3.1.2/xbase64/xbexp.cpp
---- xbase64-3.1.2/xbase64/xbexp.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbexp.cpp 2012-01-05 15:31:01.725312157 -0500
+--- a/xbase64/xbexp.cpp
++++ b/xbase64/xbexp.cpp
@@ -38,7 +38,7 @@
*/
@@ -114,9 +115,8 @@ diff -up xbase64-3.1.2/xbase64/xbexp.cpp.lesserg xbase64-3.1.2/xbase64/xbexp.cpp
#pragma implementation "xbexp.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbexp.h.lesserg xbase64-3.1.2/xbase64/xbexp.h
---- xbase64-3.1.2/xbase64/xbexp.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbexp.h 2012-01-05 15:31:01.726312148 -0500
+--- a/xbase64/xbexp.h
++++ b/xbase64/xbexp.h
@@ -42,7 +42,7 @@
#ifndef __XB_EXP_H__
#define __XB_EXP_H__
@@ -126,9 +126,8 @@ diff -up xbase64-3.1.2/xbase64/xbexp.h.lesserg xbase64-3.1.2/xbase64/xbexp.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbfile.cpp.lesserg xbase64-3.1.2/xbase64/xbfile.cpp
---- xbase64-3.1.2/xbase64/xbfile.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbfile.cpp 2012-01-05 15:31:01.727312139 -0500
+--- a/xbase64/xbfile.cpp
++++ b/xbase64/xbfile.cpp
@@ -39,7 +39,7 @@
*/
@@ -138,9 +137,8 @@ diff -up xbase64-3.1.2/xbase64/xbfile.cpp.lesserg xbase64-3.1.2/xbase64/xbfile.c
#pragma implementation "xbfile.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbfile.h.lesserg xbase64-3.1.2/xbase64/xbfile.h
---- xbase64-3.1.2/xbase64/xbfile.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbfile.h 2012-01-05 15:31:01.728312130 -0500
+--- a/xbase64/xbfile.h
++++ b/xbase64/xbfile.h
@@ -45,7 +45,7 @@
#ifndef __XB_FILE_H__
#define __XB_FILE_H__
@@ -150,9 +148,8 @@ diff -up xbase64-3.1.2/xbase64/xbfile.h.lesserg xbase64-3.1.2/xbase64/xbfile.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbfilter.cpp.lesserg xbase64-3.1.2/xbase64/xbfilter.cpp
---- xbase64-3.1.2/xbase64/xbfilter.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbfilter.cpp 2012-01-05 15:31:01.729312120 -0500
+--- a/xbase64/xbfilter.cpp
++++ b/xbase64/xbfilter.cpp
@@ -38,7 +38,7 @@
*/
@@ -162,9 +159,8 @@ diff -up xbase64-3.1.2/xbase64/xbfilter.cpp.lesserg xbase64-3.1.2/xbase64/xbfilt
#pragma implementation "xbfilter.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbfilter.h.lesserg xbase64-3.1.2/xbase64/xbfilter.h
---- xbase64-3.1.2/xbase64/xbfilter.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbfilter.h 2012-01-05 15:31:01.731312101 -0500
+--- a/xbase64/xbfilter.h
++++ b/xbase64/xbfilter.h
@@ -44,7 +44,7 @@
#ifndef __XB_FILTER_H__
#define __XB_FILTER_H__
@@ -174,9 +170,8 @@ diff -up xbase64-3.1.2/xbase64/xbfilter.h.lesserg xbase64-3.1.2/xbase64/xbfilter
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbindex.cpp.lesserg xbase64-3.1.2/xbase64/xbindex.cpp
---- xbase64-3.1.2/xbase64/xbindex.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbindex.cpp 2012-01-05 15:31:01.732312092 -0500
+--- a/xbase64/xbindex.cpp
++++ b/xbase64/xbindex.cpp
@@ -37,7 +37,7 @@
USA
*/
@@ -186,9 +181,8 @@ diff -up xbase64-3.1.2/xbase64/xbindex.cpp.lesserg xbase64-3.1.2/xbase64/xbindex
#pragma implementation "xbindex.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbindex.h.lesserg xbase64-3.1.2/xbase64/xbindex.h
---- xbase64-3.1.2/xbase64/xbindex.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbindex.h 2012-01-05 15:31:01.733312083 -0500
+--- a/xbase64/xbindex.h
++++ b/xbase64/xbindex.h
@@ -43,7 +43,7 @@
#ifndef __XB_INDEX_H__
#define __XB_INDEX_H__
@@ -198,9 +192,8 @@ diff -up xbase64-3.1.2/xbase64/xbindex.h.lesserg xbase64-3.1.2/xbase64/xbindex.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xblock.cpp.lesserg xbase64-3.1.2/xbase64/xblock.cpp
---- xbase64-3.1.2/xbase64/xblock.cpp.lesserg 2012-01-05 15:31:01.696312427 -0500
-+++ xbase64-3.1.2/xbase64/xblock.cpp 2012-01-05 15:31:01.734312074 -0500
+--- a/xbase64/xblock.cpp
++++ b/xbase64/xblock.cpp
@@ -42,7 +42,7 @@
USA
*/
@@ -210,9 +203,8 @@ diff -up xbase64-3.1.2/xbase64/xblock.cpp.lesserg xbase64-3.1.2/xbase64/xblock.c
#pragma implementation "xblock.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xblock.h.lesserg xbase64-3.1.2/xbase64/xblock.h
---- xbase64-3.1.2/xbase64/xblock.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xblock.h 2012-01-05 15:31:01.735312065 -0500
+--- a/xbase64/xblock.h
++++ b/xbase64/xblock.h
@@ -44,7 +44,7 @@
#ifndef __XB_XBLOCK_H__
#define __XB_XBLOCK_H__
@@ -222,9 +214,8 @@ diff -up xbase64-3.1.2/xbase64/xblock.h.lesserg xbase64-3.1.2/xbase64/xblock.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbndx.cpp.lesserg xbase64-3.1.2/xbase64/xbndx.cpp
---- xbase64-3.1.2/xbase64/xbndx.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbndx.cpp 2012-01-05 15:31:01.737312045 -0500
+--- a/xbase64/xbndx.cpp
++++ b/xbase64/xbndx.cpp
@@ -36,7 +36,7 @@
*/
@@ -234,9 +225,8 @@ diff -up xbase64-3.1.2/xbase64/xbndx.cpp.lesserg xbase64-3.1.2/xbase64/xbndx.cpp
#pragma implementation "xbndx.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbndx.h.lesserg xbase64-3.1.2/xbase64/xbndx.h
---- xbase64-3.1.2/xbase64/xbndx.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbndx.h 2012-01-05 15:31:01.738312036 -0500
+--- a/xbase64/xbndx.h
++++ b/xbase64/xbndx.h
@@ -41,7 +41,7 @@
#ifndef __XB_NDX_H__
#define __XB_NDX_H__
@@ -246,9 +236,8 @@ diff -up xbase64-3.1.2/xbase64/xbndx.h.lesserg xbase64-3.1.2/xbase64/xbndx.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbntx.cpp.lesserg xbase64-3.1.2/xbase64/xbntx.cpp
---- xbase64-3.1.2/xbase64/xbntx.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbntx.cpp 2012-01-05 15:31:01.740312018 -0500
+--- a/xbase64/xbntx.cpp
++++ b/xbase64/xbntx.cpp
@@ -40,7 +40,7 @@
USA
*/
@@ -258,9 +247,8 @@ diff -up xbase64-3.1.2/xbase64/xbntx.cpp.lesserg xbase64-3.1.2/xbase64/xbntx.cpp
#pragma implementation "xbntx.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbntx.h.lesserg xbase64-3.1.2/xbase64/xbntx.h
---- xbase64-3.1.2/xbase64/xbntx.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbntx.h 2012-01-05 15:31:01.741312009 -0500
+--- a/xbase64/xbntx.h
++++ b/xbase64/xbntx.h
@@ -42,7 +42,7 @@
#ifndef __XB_NTX_H__
#define __XB_NTX_H__
@@ -270,9 +258,8 @@ diff -up xbase64-3.1.2/xbase64/xbntx.h.lesserg xbase64-3.1.2/xbase64/xbntx.h
#pragma interface
#endif
-diff -up xbase64-3.1.2/xbase64/xbstring.cpp.lesserg xbase64-3.1.2/xbase64/xbstring.cpp
---- xbase64-3.1.2/xbase64/xbstring.cpp.lesserg 2006-07-17 12:54:42.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbstring.cpp 2012-01-05 15:31:01.742312000 -0500
+--- a/xbase64/xbstring.cpp
++++ b/xbase64/xbstring.cpp
@@ -38,7 +38,7 @@
*/
@@ -282,9 +269,8 @@ diff -up xbase64-3.1.2/xbase64/xbstring.cpp.lesserg xbase64-3.1.2/xbase64/xbstri
#pragma implementation "xbstring.h"
#endif
-diff -up xbase64-3.1.2/xbase64/xbstring.h.lesserg xbase64-3.1.2/xbase64/xbstring.h
---- xbase64-3.1.2/xbase64/xbstring.h.lesserg 2006-07-17 12:54:50.000000000 -0400
-+++ xbase64-3.1.2/xbase64/xbstring.h 2012-01-05 15:31:01.743311990 -0500
+--- a/xbase64/xbstring.h
++++ b/xbase64/xbstring.h
@@ -41,7 +41,7 @@
#ifndef __XBSTRING_H__
#define __XBSTRING_H__
diff --git a/debian/patches/series b/debian/patches/series
index 9721eb0..ff72ecd 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,3 +4,4 @@ autoconf-updates.diff
lesserg.diff
c++-includes.diff
gcc-fixes.diff
+fix-types-include.diff
diff --git a/debian/rules b/debian/rules
index 8afa698..58c349a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,6 +29,9 @@ override_dh_install:
chmod -x examples/*.cpp
dh_install
+override_dh_installdocs:
+ dh_installdocs -A --link-doc=libxbase64-doc
+
override_dh_makeshlibs:
dpkg-gensymbols -plibxbase64-1
dh_makeshlibs
diff --git a/debian/watch b/debian/watch
index 3c7a383..b667e5d 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,2 +1,2 @@
version=3
-http://sf.net/xdb/xbase64-([\d.]+)\.tar\.gz
+http://qa.debian.org/watch/sf.php/xdb/xbase64[_\-](\d\S*)\.(?:tar\.xz|txz|tar\.bz2|tbz2|tar\.gz|tgz)