summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d22fd74..eae81b9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+#export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
@@ -28,6 +28,12 @@ override_dh_auto_configure:
override_dh_install:
chmod -x examples/*.cpp
dh_install
+ #
+ # rename arch-dependent file to name-MULTIARCH.ext
+ # and link to the old name
+ #
+ mv -f $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64/xbconfig.h $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64/xbconfig-$(DEB_HOST_MULTIARCH).h
+ cd $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64 && ln -rs xbconfig-$(DEB_HOST_MULTIARCH).h xbconfig.h
override_dh_installdocs:
dh_installdocs -A --link-doc=libxbase64-doc