summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules42
1 files changed, 42 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6424b10
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,42 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all, optimize=-lto
+
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+
+
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-static
+
+override_dh_install-arch:
+ chmod -x examples/*.cpp
+ dh_install
+ #
+ # rename arch-dependent file to name-MULTIARCH.ext
+ # and link to the old name
+ #
+ mv -f $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64/xbconfig.h $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64/xbconfig-$(DEB_HOST_MULTIARCH).h
+ cd $(CURDIR)/debian/libxbase64-dev/usr/include/xbase64 && ln -rs xbconfig-$(DEB_HOST_MULTIARCH).h xbconfig.h
+
+override_dh_install-indep:
+ chmod -x examples/*.cpp
+ dh_install
+
+override_dh_makeshlibs:
+ dpkg-gensymbols -plibxbase64-1
+ dh_makeshlibs