summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rwxr-xr-xexamples/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100755
index 0000000..248b1ec
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,23 @@
+
+INCLUDES= -I$(topdir) $(all_includes)
+LDADD = -L$(topdir)/xbase64 -lxbase64
+
+# for shadow passwords override the value
+INSTALL_PROGRAM = @INSTALL@
+
+noinst_PROGRAMS = sample1 sample2 sample3 sample4 sample5 \
+ exfilter xbstring
+
+exfilter_SOURCES = exfilter.cpp
+sample1_SOURCES = sample1.cpp
+sample2_SOURCES = sample2.cpp
+sample3_SOURCES = sample3.cpp
+sample4_SOURCES = sample4.cpp
+sample5_SOURCES = sample5.cpp
+xbstring_SOURCES = xbstring.cpp
+
+noinst_HEADERS =
+
+EXTRA_DIST = makebcc.bat
+
+CLEANFILES = Makefile.in *.obj *.exe *.dbf *.dbt *.ndx *.ntx compout *.tds *.bak