summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien BLACHE <jblache@debian.org>2007-02-27 22:22:40 +0100
committerMattia Rizzolo <mattia@mapreri.org>2014-10-03 14:05:34 +0000
commit4d8384e7b116e3eb11cc3df9151c8554dbca95fc (patch)
treef049f1240de8a8a971a621a4a3891d5eab2839a1 /debian/rules
parent92f35807f68b30405639d4e0a95f748b6bdb793f (diff)
parent129ed4b29e21fdb8bda3bee89c3e5d8cca6ba749 (diff)
Imported Debian patch 0.993-1debian/0.993-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 7a628fd..696e018 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ endif
autotools: autotools-stamp
autotools-stamp:
- rm -f config.sub config.guess
+ -rm -f config.sub config.guess
ln -s /usr/share/misc/config.sub config.sub
ln -s /usr/share/misc/config.guess config.guess
touch autotools-stamp
@@ -54,10 +54,10 @@ real-clean:
rm -f autotools-stamp build-stamp
# Add here commands to clean up after the build process.
- [ ! -f Makefile ] || $(MAKE) distclean
+ -$(MAKE) distclean
- rm -f config.sub config.guess
- rm -f po/*.gmo
+ -rm -f config.sub config.guess
+ -rm -f po/*.gmo
dh_clean
@@ -130,7 +130,6 @@ binary-indep: build install
dh_installman -i
# dh_installinfo -i
dh_installchangelogs -i
- dh_link -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
@@ -147,12 +146,15 @@ binary-arch: build install
dh_installmenu -a
dh_installman -a
# dh_installinfo -a
+# dh_undocumented -a
dh_installchangelogs -a xsane.CHANGES
dh_link -a
dh_strip -a
dh_compress -a
dh_fixperms -a
+# dh_makeshlibs -a
dh_installdeb -a
+# dh_perl -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a