summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJulien BLACHE <jblache@debian.org>2007-11-22 11:42:18 +0100
committerMattia Rizzolo <mattia@mapreri.org>2014-10-03 14:05:42 +0000
commit95475333e13157b2a9b62c57be7c82d99e0c4460 (patch)
tree3726327549b591aba1510ff4e56317c12b276243 /debian/rules
parent0db1f3318701235603f80455d7d1e5c1709e5eb1 (diff)
parent41b1173190f702693b0b4fd2654cf2dc28a447f4 (diff)
Imported Debian patch 0.995-1debian/0.995-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 5 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 696e018..7a628fd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ endif
autotools: autotools-stamp
autotools-stamp:
- -rm -f config.sub config.guess
+ rm -f config.sub config.guess
ln -s /usr/share/misc/config.sub config.sub
ln -s /usr/share/misc/config.guess config.guess
touch autotools-stamp
@@ -54,10 +54,10 @@ real-clean:
rm -f autotools-stamp build-stamp
# Add here commands to clean up after the build process.
- -$(MAKE) distclean
+ [ ! -f Makefile ] || $(MAKE) distclean
- -rm -f config.sub config.guess
- -rm -f po/*.gmo
+ rm -f config.sub config.guess
+ rm -f po/*.gmo
dh_clean
@@ -130,6 +130,7 @@ binary-indep: build install
dh_installman -i
# dh_installinfo -i
dh_installchangelogs -i
+ dh_link -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
@@ -146,15 +147,12 @@ binary-arch: build install
dh_installmenu -a
dh_installman -a
# dh_installinfo -a
-# dh_undocumented -a
dh_installchangelogs -a xsane.CHANGES
dh_link -a
dh_strip -a
dh_compress -a
dh_fixperms -a
-# dh_makeshlibs -a
dh_installdeb -a
-# dh_perl -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a