summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 4 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 696e018..daa272b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,7 @@ endif
autotools: autotools-stamp
autotools-stamp:
- -rm -f config.sub config.guess
+ rm -f config.sub config.guess
ln -s /usr/share/misc/config.sub config.sub
ln -s /usr/share/misc/config.guess config.guess
touch autotools-stamp
@@ -54,10 +54,10 @@ real-clean:
rm -f autotools-stamp build-stamp
# Add here commands to clean up after the build process.
- -$(MAKE) distclean
+ [ ! -f Makefile ] || $(MAKE) distclean
- -rm -f config.sub config.guess
- -rm -f po/*.gmo
+ rm -f config.sub config.guess
+ rm -f po/*.gmo
dh_clean
@@ -146,15 +146,12 @@ binary-arch: build install
dh_installmenu -a
dh_installman -a
# dh_installinfo -a
-# dh_undocumented -a
dh_installchangelogs -a xsane.CHANGES
dh_link -a
dh_strip -a
dh_compress -a
dh_fixperms -a
-# dh_makeshlibs -a
dh_installdeb -a
-# dh_perl -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a