summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-09-11 05:05:43 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-09-11 05:05:43 +0200
commit989c1bf333bfe7d37f22141a69b9bec0b1dfdd69 (patch)
tree1d51776e8e10e353df57b94561cdeb31d75c6cc4
parent029b7c005d0e0dc0bf64fcd09d7d8b72c3a6b7dc (diff)
New 0105-Fix_path_handling_bug.patchdebian/4.0.0-6
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/0105-Fix_path_handling_bug.patch19
-rw-r--r--debian/patches/series1
3 files changed, 23 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 9812548..0f7bff7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-xsd (4.0.0-6) UNRELEASED; urgency=medium
+xsd (4.0.0-6) unstable; urgency=medium
* Fix parallel building (Closes: #823271).
Thanks to Pino Toscano <pino@debian.org>
@@ -8,8 +8,9 @@ xsd (4.0.0-6) UNRELEASED; urgency=medium
* debian/copyright:
- Move the license text in alphabetical order to the end.
- Remove trailing whitespaces.
+ * New upstream patch: 0105-Fix_path_handling_bug.patch.
- -- Jörg Frings-Fürst <debian@jff-webhosting.net> Fri, 02 Sep 2016 11:31:04 +0200
+ -- Jörg Frings-Fürst <debian@jff-webhosting.net> Sun, 11 Sep 2016 04:49:55 +0200
xsd (4.0.0-5) unstable; urgency=medium
diff --git a/debian/patches/0105-Fix_path_handling_bug.patch b/debian/patches/0105-Fix_path_handling_bug.patch
new file mode 100644
index 0000000..de893b1
--- /dev/null
+++ b/debian/patches/0105-Fix_path_handling_bug.patch
@@ -0,0 +1,19 @@
+Description: Fix path handling bug
+Author: Boris Kolpackov <boris@codesynthesis.com>
+Origin: git commit b4c3242a763e0461f454cc29be28c2ab26e4a495
+Last-Update: 2016-09-10
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/xsd/examples/cxx/tree/embedded/xsdbin.cxx
+===================================================================
+--- trunk.orig/xsd/examples/cxx/tree/embedded/xsdbin.cxx
++++ trunk/xsd/examples/cxx/tree/embedded/xsdbin.cxx
+@@ -334,7 +334,7 @@ main (int argc, char* argv[])
+ //
+ string::size_type p (base.rfind ('/')), p1 (base.rfind ('\\'));
+
+- if (p1 != string::npos && p1 > p)
++ if (p1 != string::npos && (p == string::npos || p1 > p))
+ p = p1;
+
+ if (p != string::npos)
diff --git a/debian/patches/series b/debian/patches/series
index 999f227..ca892aa 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0100-C++Parser_Expat_support.patch
0001-xsd_xsdcxx-rename.patch
0700_hurd_PATH_MAX.patch
+0105-Fix_path_handling_bug.patch