summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-02-07 19:01:56 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-02-07 19:01:56 +0100
commitfdcdf49663e60b3c291a0c492e008e4ff3865a59 (patch)
tree0e11df978516bc10725f112c877a3672d34da95d /debian/rules
parent01ece1ff30eb3dda4a9529f413801718e01c2547 (diff)
Add test for NO_CPUS == 0
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 391d831..f1fe1f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,10 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#
# Get the number of cpus
#
-NO_CPUS=$(shell cat /proc/cpuinfo | grep processor | wc -l)
+NO_CPUS=$(shell nproc)
+ifeq ($(NO_CPUS),0)
+NO_CPUS=1
+endif
export verbose=1