summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-08-19 11:18:46 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-08-19 11:18:46 +0200
commitaf4733cb070fc0b44bdb556a41e1c86c3b668e7b (patch)
treebe93f0232dd606fbe80b88937df78352ca76aaf4 /debian
parent59094379f99899ab9a5fb60f525191cba9581174 (diff)
increase verbosity
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/rules5
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ae3c6b3..9c7ce45 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,11 @@ xsd (4.0.0-2) UNRELEASED; urgency=medium
* debian/rules:
- Add "make xsd_clean_gen=n clean" to override_dh_clean to
build the cli at build time (Closes: #794440).
+ - Reduce buildtime (Closes: #795545):
+ + Add overrides for dh_auto_build and dh_auto_test to change
+ the make parameter -j to the current number of CPUs.
+ + Add --parallel to dh call.
+ + Add "export verbose=1" to increase the verbosity (Closes: #795547).
* debian/control:
- Bump Standards-Version to 3.9.6 (no changes required).
* debian/copyright:
diff --git a/debian/rules b/debian/rules
index b735031..73b274a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,8 +23,13 @@ include /usr/share/dpkg/buildflags.mk
#export CC=gcc-5
#export CXX=g++-5
+#
+# Get the number of cpus
+#
NO_CPUS=$(shell cat /proc/cpuinfo | grep processor | wc -l)
+export verbose=1
+
%:
dh $@ --with autotools-dev --parallel