summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2828376..b735031 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,8 +23,16 @@ include /usr/share/dpkg/buildflags.mk
#export CC=gcc-5
#export CXX=g++-5
+NO_CPUS=$(shell cat /proc/cpuinfo | grep processor | wc -l)
+
%:
- dh $@ --with autotools-dev
+ dh $@ --with autotools-dev --parallel
+
+override_dh_auto_build:
+ make -j$(NO_CPUS)
+
+override_dh_auto_test:
+ make -j$(NO_CPUS) test
override_dh_clean:
rm -f $(CURDIR)/libcult/build/system/configuration-dynamic.make