summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 391d831..f1fe1f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,10 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#
# Get the number of cpus
#
-NO_CPUS=$(shell cat /proc/cpuinfo | grep processor | wc -l)
+NO_CPUS=$(shell nproc)
+ifeq ($(NO_CPUS),0)
+NO_CPUS=1
+endif
export verbose=1