Description: change docu from xsd to xsdcxx Author: Jörg Frings-Fürst Forwarded: not-needed Last-Update: 2014-07-22 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ Index: trunk/xsd/doc/xsd.1 =================================================================== --- trunk.orig/xsd/doc/xsd.1 2014-07-21 08:38:41.000000000 +0200 +++ trunk/xsd/doc/xsd.1 2014-07-21 23:27:00.928980158 +0200 @@ -1,16 +1,16 @@ .\" Process this file with .\" groff -man -Tascii xsd.1 .\" -.TH XSD 1 "July 2014" "XSD 4.0.0" +.TH XSDCXX 1 "July 2014" "XSDCXX 4.0.0" .SH NAME -xsd \- W3C XML Schema to C++ Compiler +xsdcxx \- W3C XML Schema to C++ Compiler .\" .\" .\" .\"-------------------------------------------------------------------- .SH SYNOPSIS .\"-------------------------------------------------------------------- -.B xsd +.B xsdcxx .I command .B [ .I options @@ -20,19 +20,19 @@ .I file .B ...] .in -.B xsd help +.B xsdcxx help .B [ .I command .B ] .in -.B xsd version +.B xsdcxx version .\" .\" .\" .\"-------------------------------------------------------------------- .SH DESCRIPTION .\"-------------------------------------------------------------------- -.B xsd +.B xsdcxx generates vocabulary-specific, statically-typed C++ mapping from W3C XML Schema definitions. Particular mapping to produce is selected by a .IR command . @@ -96,7 +96,7 @@ .PP .RS .RS 3 -.B xsd help +.B xsdcxx help .I command .RE .PP @@ -133,9 +133,9 @@ When the C++11 mode is selected, you normally don't need to perform any extra steps other than enable C++11 in your C++ compiler, if required\. The -XSD compiler will automatically add the necessary macro defines to the -generated header files that will switch the header-only XSD runtime library -(\fBlibxsd\fP) to the C++11 mode\. However, if you include any of the XSD +XSDCXX compiler will automatically add the necessary macro defines to the +generated header files that will switch the header-only XSDCXX runtime library +(\fBlibxsd\fP) to the C++11 mode\. However, if you include any of the XSDCXX runtime headers directly in your application (normally you just include the generated headers), then you will need to define the \fBXSD_CXX11\fP macro for your entire project\. @@ -1632,7 +1632,7 @@ .\" .SH DIAGNOSTICS If the input file is not a valid W3C XML Schema definition, -.B xsd +.B xsdcxx will issue diagnostic messages to .B STDERR and exit with non-zero exit code. Index: trunk/xsd/doc/xsd.xhtml =================================================================== --- trunk.orig/xsd/doc/xsd.xhtml 2014-07-21 08:38:41.000000000 +0200 +++ trunk/xsd/doc/xsd.xhtml 2014-07-21 23:29:32.796093697 +0200 @@ -3,11 +3,11 @@ - XSD 4.0.0 Compiler Command Line Manual + XSDCXX 4.0.0 Compiler Command Line Manual - + @@ -50,19 +50,19 @@

NAME

-

xsd - W3C XML Schema to C++ Compiler

+

xsdcxx - W3C XML Schema to C++ Compiler

SYNOPSIS

-
xsd command [options] file [file ...]
-
xsd help [command]
-
xsd version
+
xsdcxx command [options] file [file ...]
+
xsdcxx help [command]
+
xsdcxx version

DESCRIPTION

-

xsd generates vocabulary-specific, statically-typed +

xsdcxx generates vocabulary-specific, statically-typed C++ mapping from W3C XML Schema definitions. Particular mapping to produce is selected by a command. Each mapping has a number of mapping-specific options that should @@ -138,10 +138,10 @@

When the C++11 mode is selected, you normally don't need to perform any extra steps other than enable C++11 in your C++ compiler, if required. The - XSD compiler will automatically add the necessary macro defines to the - generated header files that will switch the header-only XSD runtime library + XSDCXX compiler will automatically add the necessary macro defines to the + generated header files that will switch the header-only XSDCXX runtime library (libxsd) to the C++11 mode. However, if you include any - of the XSD runtime headers directly in your application (normally you just + of the XSDCXX runtime headers directly in your application (normally you just include the generated headers), then you will need to define the XSD_CXX11 macro for your entire project.

@@ -219,7 +219,7 @@

For example, if you have file hello.xsd with namespace http://example.com/hello and you run - xsd on this file, then the string in question will + xsdcxx on this file, then the string in question will be:

hello.xsd. http://example.com/hello

@@ -1530,7 +1530,7 @@

DIAGNOSTICS

If the input file is not a valid W3C XML Schema definition, - xsd will issue diagnostic messages to STDERR + xsdcxx will issue diagnostic messages to STDERR and exit with non-zero exit code.

BUGS