Description: change docu from xsd to xsdcxx Author: Jörg Frings-Fürst Reviewed-by: Last-Update: 2014-04-13 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ Index: work/xsd/documentation/xsd.1 =================================================================== --- work.orig/xsd/documentation/xsd.1 2010-04-22 13:28:43.000000000 +0200 +++ work/xsd/documentation/xsd.1 2010-11-19 10:15:53.824581814 +0100 @@ -1,16 +1,16 @@ .\" Process this file with .\" groff -man -Tascii xsd.1 .\" -.TH XSD 1 "April 2010" "XSD 3.3.0" +.TH XSDCXX 1 "April 2010" "XSD 3.3.0" .SH NAME -xsd \- W3C XML Schema to C++ Compiler +xsdcxx \- W3C XML Schema to C++ Compiler .\" .\" .\" .\"-------------------------------------------------------------------- .SH SYNOPSIS .\"-------------------------------------------------------------------- -.B xsd +.B xsdcxx .I command .B [ .I options @@ -20,19 +20,19 @@ .I file .B ...] .in -.B xsd help +.B xsdcxx help .B [ .I command .B ] .in -.B xsd version +.B xsdcxx version .\" .\" .\" .\"-------------------------------------------------------------------- .SH DESCRIPTION .\"-------------------------------------------------------------------- -.B xsd +.B xsdcxx generates vocabulary-specific, statically-typed C++ mapping from W3C XML Schema definitions. Particular mapping to produce is selected by a .IR command . @@ -96,7 +96,7 @@ .PP .RS .RS 3 -.B xsd help +.B xsdcxx help .I command .RE .PP @@ -203,7 +203,7 @@ with namespace .B http://example.com/hello and you run -.B xsd +.B xsdcxx on this file, then the string in question will be: .B hello.xsd. http://example.com/hello @@ -1877,7 +1877,7 @@ .\" .SH DIAGNOSTICS If the input file is not a valid W3C XML Schema definition, -.B xsd +.B xsdcxx will issue diagnostic messages to .B STDERR and exit with non-zero exit code. Index: work/xsd-srcdir/xsd/documentation/xsd.xhtml =================================================================== --- work.orig/xsd/documentation/xsd.xhtml 2010-02-22 13:38:06.000000000 +0100 +++ work/xsd/documentation/xsd.xhtml 2010-11-19 10:15:11.900404798 +0100 @@ -50,19 +50,19 @@

NAME

-

xsd - W3C XML Schema to C++ Compiler

+

xsdcxx - W3C XML Schema to C++ Compiler

SYNOPSIS

-
xsd command [options] file [file ...]
-
xsd help [command]
-
xsd version
+
xsdcxx command [options] file [file ...]
+
xsdcxx help [command]
+
xsdcxx version

DESCRIPTION

-

xsd generates vocabulary-specific, statically-typed +

xsdcxx generates vocabulary-specific, statically-typed C++ mapping from W3C XML Schema definitions. Particular mapping to produce is selected by a command. Each mapping has a number of mapping-specific options that should @@ -104,7 +104,7 @@

help
Print usage information and exit. Use -

xsd help command

+

xsdcxx help command

for command-specific help.
@@ -174,7 +174,7 @@

For example, if you have file hello.xsd with namespace http://example.com/hello and you run - xsd on this file, then the string in question + xsdcxx on this file, then the string in question will be:

hello.xsd. http://example.com/hello

@@ -1575,7 +1575,7 @@

DIAGNOSTICS

If the input file is not a valid W3C XML Schema definition, - xsd will issue diagnostic messages to STDERR + xsdcxx will issue diagnostic messages to STDERR and exit with non-zero exit code.

BUGS