summaryrefslogtreecommitdiff
path: root/app/help/xtrkcad.tip
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2020-08-24 21:26:53 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2020-08-24 21:26:53 +0200
commitdf247efec654e512242e4f4f1b0212034f9e01fe (patch)
tree25c02e16957f3aa613af30c140fd8e8a3d52fda6 /app/help/xtrkcad.tip
parentd0b6a8a4ec298024f14f704f9e40a6f9d324ccf3 (diff)
parenta5ade52caa489cf0a713e0f02b764000d203140e (diff)
Merge branch 'release/debian/1%5.2.0Beta2.1-1' into masterHEADdebian/1%5.2.0Beta2.1-1master
Diffstat (limited to 'app/help/xtrkcad.tip')
-rw-r--r--app/help/xtrkcad.tip65
1 files changed, 37 insertions, 28 deletions
diff --git a/app/help/xtrkcad.tip b/app/help/xtrkcad.tip
index 8deffc6..bcc15c3 100644
--- a/app/help/xtrkcad.tip
+++ b/app/help/xtrkcad.tip
@@ -1,17 +1,17 @@
XTrackCAD provides demonstrations on most of the program's features. The demos can be run by clicking on the Help menu on the Main window and then selecting Demos.
The notation "Menu|Item" is used in the documentation (and the on-line demos and tips) to indicate the selection of a menu item.\
-For example File|Open means to open the menu by clicking on File on the menu bar of the Main window and then selecting the Open item from that menu.
+For example, "File|Open" means to open the menu by clicking on File on the menu bar of the Main window and then selecting the Open item from that menu.
-A number of example layouts are provided. These files are located in the 'examples' directory where you installed XTrackCAD. The "File|Open" command will open that directory when first used.
+Set your modeling scale on the "Options|Layout" dialog. This controls the Turnouts and Structures that are available, Easement values and track gauge.
-When installed, the program measures all units in inches. You can change this on the "Options|Preferences" dialog by changing the Units item to Metric instead of English.
+A number of example layouts are provided. These files can be accessed by "Help|Examples".
-You can change the overall size of your layout on the "Options|Layout" dialog.
+When installed, the length units are set based on your contry: inches for United States or Canada and centimeters elsewhere. You can change this on the "Options|Preferences" dialog by choosing between Metric and English.
-When installed, the default command is the Describe command. More experienced users will probably want to change this to the Select command. You can do this on the "Options|Command Options" dialog.
+You can change the overall size of your layout on the "Options|Layout" dialog.
-Set your modeling scale on the "Options|Layout" dialog. This controls the Turnouts and Structures that are available, Easement values and track gauge.
+When installed, the default command is the Select command. You might want to change this to the Decribe command. You can do this on the "Options|Command Options" dialog.
When Selecting tracks, the connection between Selected and Unselected tracks is marked by a Red X. This indicates points where the connection between tracks will be broken if you Move or Rotate the Selected tracks.
@@ -22,14 +22,14 @@ You can add track to any unconnected End-Point with the Modify command.\
Hold down the Shift key and click on the End-Point and drag away to create a new track segment attached to the End-Point.\
Repeat with the new End-Point to create flowing tracks.
-You can create Curved tracks in four ways by dragging from:\
- the 1st End-Point in the direction of the curve\
- Center of the Curve to the 1st End-Point\
- End-Point to the Center\
- the 1st to 2nd End-Point\
+You can create curved tracks in four ways by dragging from:\
+ the 1st endpoint in the direction of the curve\
+ center of the curve to the 1st endpoint\
+ endpoint to the center\
+ the 1st to 2nd endpoint\
Then drag on one of the Red arrows to create the final shape of the curve.\
\
-You can click on the small button to the left of the Curve command button to change the method.
+You can click on the small button to the right of the Curve command button to change the method.
When creating a straight or a curved track by dragging from the 1st End Point, you can snap the new track to an existing open end point by holding down Shift while you click.\
The new track will be joined to the old when you create it.
@@ -49,7 +49,7 @@ The Easement dialog is used to control easements.
"Help|Recent Messages" shows the last error and warning messages that were generated by the program. Also an explanation of each message is displayed.
When creating stall tracks for a turntable, you usually want the the stall tracks to be spaced evenly.\
-The "Turntable Angle" item on "Options|Command Options" dialog can be used specify the minimum angle between stall tracks.
+The "Turntable Angle" item on "Options|Preferences" dialog can be used specify the minimum angle between stall tracks.
XTrackCAD periodically saves the current layout in a check point file. The 'Check Point' item on the 'Options|Preferences' dialog controls how often the file is saved.\
You can recover your working file after a system crash by copying the checkpoint file (xtrkcad.ckp in the XTrackCAD Working directory) to file.xtc
@@ -73,12 +73,13 @@ Select the track at the beginning and end of the section. The total length of t
Note: the Profile selects the shortest path between the two selected tracks, which might not be the path you are interested in. In this case, select the first track and then select other tracks along the path.
Layers can be used to contain different groups of tracks or other features. You might use one layer for the main-line, another of staging tracks and another of benchwork.\
-You can give each layer a name (by using the Layer dialog). This name will be displayed as the Balloon Help for the corresponding Layer button, if you have Balloon Help enabled on the Display dialog.
-You can remove groups of buttons or the Hot Bar from the Main window to give you more room if you are not using some features. Also, the number of Layer buttons displayed is controlled by the Layers dialog.
+You can give each layer a name (by using the "Manage|Layer" dialog). This name will be displayed as the Balloon Help for the corresponding Layer button, if you have Balloon Help enabled on the "Options|Display" dialog.
-The size of the Map window is controlled by the overall size of the room (specified on the Layout dialog) and the Map Scale (on the Display dialog). You can make the Map window larger (or smaller) by decreasing (or increasing) the Map Scale.\
-XTrackCAD will prevent you from making the Map window too small or too large.
+You can remove groups of buttons or the Hot Bar from the Main window to give you more room if you are not using some features. Also, the number of Layer buttons displayed is controlled by the "Manage|Layers" dialog.
+
+The size of the map window is controlled by the overall size of the room (specified on the layout dialog) and the map scale (on the display dialog). You can make the Map window larger (or smaller) by decreasing (or increasing) the map scale.\
+XTrackCad will prevent you from making the map window too small or too large.
You can unload parameter files you are not using by the Parameter Files dialog. This removes unused Turnout and Structure definitions from the Hot Bar and makes the program start faster.
@@ -107,7 +108,7 @@ The colors of different parts of the Main window can be changed with the Colors
By default objects are drawn in their normal colors. Tracks will be drawn in Black. Objects can also be drawn in the color according to their Layer. The color of a Layer is displayed on the corresponding Layer button.\
The Display dialog 'Color Layers' item has separate toggles for Tracks and non-Tracks.
-Each Layer can be drawn or hidden by the 'Visible' toggle on the Layers dialog.
+Each Layer can be drawn or hidden by the 'Visible' toggle on the Layers dialog.
Short cut Layer buttons can also be displayed on the tool bar for up to the first 20 layers.\
This buttons allow to Show or Hide the layers.
@@ -120,7 +121,7 @@ Many of the commands and dialogs can be invoked by special key combinations call
The Connect command is used to join Sectional track pieces that don't quite fit together.\
This command works by adding small gaps between other tracks to move the selected End-Points closer together.
-To copy a group of objects: Select the objects, press Control-C (or select Copy from the Edit menu), press Control-V (or select Paste from the Edit menu).\
+To copy a group of objects: Select the objects, press Control-c (or select Copy from the Edit menu), press Control-v (or select Paste from the Edit menu).\
The selected tracks will be copied to the layout and you can Move or Rotate them into position.
In the Rotate (or Select) commands you can press Shift-Right-Click to display the Rotate menu which allows you to rotate the selected objects by a specific angle.
@@ -134,7 +135,7 @@ Areas of water can represented by a Polygon (use the Draw command) of the approp
By using the Modify command, you can move, add or remove corners of the Polygon to fit the shape of the water.\
You use the Below command to place the Polygon below (or behind) other objects.\
\
-You can also use a Polygon to represent aisles.
+You can also use a Polygon to represent aisles.
When you create Benchwork you can move it below other objects by Selecting the Benchwork and use the Below command.\
Also, put Benchwork in a separate Layer so you can hide it if desired.
@@ -143,7 +144,7 @@ You can enter Distances and Lengths using any format regardless of the Length Fo
You can enter Metric values when English is the default Units and vice versa.
When entering Distances and Lengths you can press the '=' key to redisplay the value in the default format.
-You can also press the 's' key to convert a Prototype measurement to a Scale measurement y dividing by the ratio for the current scale.
+You can also press the 's' key to convert a Prototype measurement to a Scale measurement by dividing by the ratio for the current scale.
The 'p' key will convert a Scale measurement to a Prototype measurement.
You can place cars on the layout using the Train Simulation command to check clearance points, track to track separation and coupling.
@@ -197,7 +198,7 @@ You can export the selected tracks to a DXF file which can be read by most CAD p
Lengths and distances can be displayed in a variety of units and formats such as 1' 10 3/4", 1ft 10.75in or 22.750. In Metric mode, distances can be displayed as millimeters, centimeters or meters. See the Length Format item on the Preferences dialog.
-Tracks that are too steep or curve too tightly are drawn in the Expection color (Purple by default). \
+Tracks that are too steep or curve too tightly are drawn in the Exception color (Yellow by default). \
This helps to identify potential problem areas. \
The maximum grade and minimum radius are set on the Preferences dialog.
@@ -219,20 +220,28 @@ As well, the color and thickness of the lines used to represent the roadbed can
The Color dialog (on the Options menu) is used to change the color of different objects on the display. \
You can change the color of the Snap Grid and Borders, as well as Normal, Selected and Exception tracks.
-#Elevations
+You can set the elevation (height) of track end-points. \
+Elevations of intermediate end points can be computed automatically based on the distance to the nearest end points with defined elevations. \
+Grades can also be displayed at selected end points. \
+Please see the Elevations help and demo.
-#Profile
+Once you have elevations on some endpoints, you can use the Profile command to produce an elevation graph. \
+The graph shows the selected elevations, grades and distances. \
+Please see the Profile help and demo for details.
You can draw tracks with wider lines for rails. \
Select the tracks and use Medium or Thick Tracks on the Edit menu.
-#Custom TO
-
-#Helix
+The Helix command is used to create a Helix track. \
+You specify some parameters: height, radius, number of turns, grade and vertical separation between layers. \
+These values are interrelated so changing one value will affect ohers. \
+Then you can place the Helix and join to other tracks as you would a Circle track.
Many objects on the layout have labels: Turnouts/Helix/Curved Titles, Track Lenghts, End-Point Elevations, Track Elevations and Cars. \
You can turn these labels on or off with the Label Enable toggle buttons on the Display options dialog.
-If you hold down the Control key when using the Rotate command, the rotation will be down in increments of 15.
+If you hold down the Control key when using the Rotate command, the rotation will be done in increments of 15�.
When using the Rotate command, Shift-Right-Click displays a menu allowing you to rotate by specific amounts or to align the selected objects with another object.
+
+This is last tip. If you have any additions or comments, please let us know.